summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-alembic.inc15
-rw-r--r--meta-python/recipes-devtools/python/python3-alembic_1.3.2.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-alembic_1.4.0.bb17
3 files changed, 17 insertions, 17 deletions
diff --git a/meta-python/recipes-devtools/python/python-alembic.inc b/meta-python/recipes-devtools/python/python-alembic.inc
deleted file mode 100644
index c94c142ddb..0000000000
--- a/meta-python/recipes-devtools/python/python-alembic.inc
+++ /dev/null
@@ -1,15 +0,0 @@
1DESCRIPTION = "A database migration tool for SQLAlchemy"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=28aaf14a6592d14dbfb2f4abd597aa27"
4
5SRC_URI[md5sum] = "3d7584a8fb0203ec82b90baa726d2bd9"
6SRC_URI[sha256sum] = "3b0cb1948833e062f4048992fbc97ecfaaaac24aaa0d83a1202a99fb58af8c6d"
7
8PYPI_PACKAGE = "alembic"
9
10RDEPENDS_${PN} += "\
11 ${PYTHON_PN}-dateutil \
12 ${PYTHON_PN}-editor \
13 ${PYTHON_PN}-mako \
14 ${PYTHON_PN}-sqlalchemy \
15"
diff --git a/meta-python/recipes-devtools/python/python3-alembic_1.3.2.bb b/meta-python/recipes-devtools/python/python3-alembic_1.3.2.bb
deleted file mode 100644
index e248fe7ce9..0000000000
--- a/meta-python/recipes-devtools/python/python3-alembic_1.3.2.bb
+++ /dev/null
@@ -1,2 +0,0 @@
1inherit pypi setuptools3
2require python-alembic.inc
diff --git a/meta-python/recipes-devtools/python/python3-alembic_1.4.0.bb b/meta-python/recipes-devtools/python/python3-alembic_1.4.0.bb
new file mode 100644
index 0000000000..8247166da6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-alembic_1.4.0.bb
@@ -0,0 +1,17 @@
1DESCRIPTION = "A database migration tool for SQLAlchemy"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=bd64aba1b968c2bfbc2b525a181ce85c"
4
5inherit pypi setuptools3
6
7SRC_URI[md5sum] = "758b28361557e45c79c454d662131a83"
8SRC_URI[sha256sum] = "2df2519a5b002f881517693b95626905a39c5faf4b5a1f94de4f1441095d1d26"
9
10PYPI_PACKAGE = "alembic"
11
12RDEPENDS_${PN} += "\
13 ${PYTHON_PN}-dateutil \
14 ${PYTHON_PN}-editor \
15 ${PYTHON_PN}-mako \
16 ${PYTHON_PN}-sqlalchemy \
17"