diff options
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-simpleeval/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-simpleeval_0.9.10.bb | 14 |
2 files changed, 16 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-simpleeval/run-ptest b/meta-python/recipes-devtools/python/python3-simpleeval/run-ptest new file mode 100644 index 0000000000..5cec711696 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-simpleeval/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest | ||
diff --git a/meta-python/recipes-devtools/python/python3-simpleeval_0.9.10.bb b/meta-python/recipes-devtools/python/python3-simpleeval_0.9.10.bb index 633347a937..1cacf9af2a 100644 --- a/meta-python/recipes-devtools/python/python3-simpleeval_0.9.10.bb +++ b/meta-python/recipes-devtools/python/python3-simpleeval_0.9.10.bb | |||
@@ -6,6 +6,18 @@ LIC_FILES_CHKSUM = "file://LICENCE;md5=dc9277482effe59b734b004cbcc1fee7" | |||
6 | SRC_URI[md5sum] = "f175fc12d408487ca26fa3905e0a6691" | 6 | SRC_URI[md5sum] = "f175fc12d408487ca26fa3905e0a6691" |
7 | SRC_URI[sha256sum] = "692055488c2864637f6c2edb5fa48175978a2a07318009e7cf03c9790ca17bea" | 7 | SRC_URI[sha256sum] = "692055488c2864637f6c2edb5fa48175978a2a07318009e7cf03c9790ca17bea" |
8 | 8 | ||
9 | inherit pypi setuptools3 | 9 | inherit pypi setuptools3 ptest |
10 | 10 | ||
11 | BBCLASSEXTEND = "native nativesdk" | 11 | BBCLASSEXTEND = "native nativesdk" |
12 | |||
13 | SRC_URI += " \ | ||
14 | file://run-ptest \ | ||
15 | " | ||
16 | |||
17 | RDEPENDS_${PN}-ptest += " \ | ||
18 | ${PYTHON_PN}-pytest \ | ||
19 | " | ||
20 | |||
21 | do_install_ptest() { | ||
22 | cp -f ${S}/test_simpleeval.py ${D}${PTEST_PATH}/ | ||
23 | } | ||