diff options
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-rapidjson/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-rapidjson_1.19.bb | 14 |
2 files changed, 1 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python/python3-rapidjson/run-ptest b/meta-python/recipes-devtools/python/python3-rapidjson/run-ptest deleted file mode 100644 index 8d2017d39c..0000000000 --- a/meta-python/recipes-devtools/python/python3-rapidjson/run-ptest +++ /dev/null | |||
@@ -1,3 +0,0 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest --automake | ||
diff --git a/meta-python/recipes-devtools/python/python3-rapidjson_1.19.bb b/meta-python/recipes-devtools/python/python3-rapidjson_1.19.bb index bfc05a7354..5c47e06918 100644 --- a/meta-python/recipes-devtools/python/python3-rapidjson_1.19.bb +++ b/meta-python/recipes-devtools/python/python3-rapidjson_1.19.bb | |||
@@ -7,25 +7,18 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=6fe0b2465366662d7cfa6793ccbab563" | |||
7 | SRC_URI[sha256sum] = "81e7260f6297cad564389b700783c0a33de71310b9eb01fd013faec5e7ed4eff" | 7 | SRC_URI[sha256sum] = "81e7260f6297cad564389b700783c0a33de71310b9eb01fd013faec5e7ed4eff" |
8 | 8 | ||
9 | # Inheriting ptest provides functionality for packaging and installing runtime tests for this recipe | 9 | # Inheriting ptest provides functionality for packaging and installing runtime tests for this recipe |
10 | inherit setuptools3 pypi ptest | 10 | inherit setuptools3 pypi ptest-python-pytest |
11 | 11 | ||
12 | PYPI_PACKAGE = "python-rapidjson" | 12 | PYPI_PACKAGE = "python-rapidjson" |
13 | 13 | ||
14 | SETUPTOOLS_BUILD_ARGS += " --rj-include-dir=${RECIPE_SYSROOT}${includedir}" | 14 | SETUPTOOLS_BUILD_ARGS += " --rj-include-dir=${RECIPE_SYSROOT}${includedir}" |
15 | 15 | ||
16 | # run-ptest is a shell script that starts the test suite | ||
17 | SRC_URI += " \ | ||
18 | file://run-ptest \ | ||
19 | " | ||
20 | |||
21 | DEPENDS += " \ | 16 | DEPENDS += " \ |
22 | rapidjson \ | 17 | rapidjson \ |
23 | " | 18 | " |
24 | 19 | ||
25 | # Adding required python package for the ptest (pytest and pytest->automake report translation) | 20 | # Adding required python package for the ptest (pytest and pytest->automake report translation) |
26 | RDEPENDS:${PN}-ptest += " \ | 21 | RDEPENDS:${PN}-ptest += " \ |
27 | python3-pytest \ | ||
28 | python3-unittest-automake-output \ | ||
29 | python3-pytz \ | 22 | python3-pytz \ |
30 | " | 23 | " |
31 | 24 | ||
@@ -33,8 +26,3 @@ RDEPENDS:${PN} += " \ | |||
33 | python3-core \ | 26 | python3-core \ |
34 | " | 27 | " |
35 | 28 | ||
36 | # Installing the test suite on the target | ||
37 | do_install_ptest() { | ||
38 | install -d ${D}${PTEST_PATH}/tests | ||
39 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
40 | } | ||