diff options
Diffstat (limited to 'meta-python/recipes-devtools/python')
3 files changed, 50 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio/0001-absl-always-use-asm-sgidefs.h.patch b/meta-python/recipes-devtools/python/python3-grpcio/0001-absl-always-use-asm-sgidefs.h.patch new file mode 100644 index 0000000000..be516ca508 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-grpcio/0001-absl-always-use-asm-sgidefs.h.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | From 8f21fdfb83b0fa844a9f1f03a86a9ca46642d85e Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 9 Apr 2020 13:06:27 -0700 | ||
4 | Subject: [PATCH 1/2] absl: always use <asm/sgidefs.h> | ||
5 | |||
6 | Fixes mips/musl build, since sgidefs.h is not present on all C libraries | ||
7 | but on linux asm/sgidefs.h is there and contains same definitions, using | ||
8 | that makes it portable. | ||
9 | |||
10 | Upstream-Status: Pending | ||
11 | |||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | third_party/abseil-cpp/absl/base/internal/direct_mmap.h | 6 +----- | ||
15 | 1 file changed, 1 insertion(+), 5 deletions(-) | ||
16 | |||
17 | --- a/third_party/abseil-cpp/absl/base/internal/direct_mmap.h | ||
18 | +++ b/third_party/abseil-cpp/absl/base/internal/direct_mmap.h | ||
19 | @@ -41,13 +41,9 @@ | ||
20 | |||
21 | #ifdef __mips__ | ||
22 | // Include definitions of the ABI currently in use. | ||
23 | -#ifdef __BIONIC__ | ||
24 | -// Android doesn't have sgidefs.h, but does have asm/sgidefs.h, which has the | ||
25 | +// bionic/musl C libs don't have sgidefs.h, but do have asm/sgidefs.h, which has the | ||
26 | // definitions we need. | ||
27 | #include <asm/sgidefs.h> | ||
28 | -#else | ||
29 | -#include <sgidefs.h> | ||
30 | -#endif // __BIONIC__ | ||
31 | #endif // __mips__ | ||
32 | |||
33 | // SYS_mmap and SYS_munmap are not defined in Android. | ||
diff --git a/meta-python/recipes-devtools/python/python3-grpcio/mips_bigendian.patch b/meta-python/recipes-devtools/python/python3-grpcio/mips_bigendian.patch new file mode 100644 index 0000000000..343f25a46e --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-grpcio/mips_bigendian.patch | |||
@@ -0,0 +1,15 @@ | |||
1 | --- a/third_party/boringssl-with-bazel/src/include/openssl/base.h | ||
2 | +++ b/third_party/boringssl-with-bazel/src/include/openssl/base.h | ||
3 | @@ -102,10 +102,10 @@ extern "C" { | ||
4 | #elif (defined(__PPC__) || defined(__powerpc__)) | ||
5 | #define OPENSSL_32_BIT | ||
6 | #define OPENSSL_PPC | ||
7 | -#elif defined(__MIPSEL__) && !defined(__LP64__) | ||
8 | +#elif defined(__mips__) && !defined(__LP64__) | ||
9 | #define OPENSSL_32_BIT | ||
10 | #define OPENSSL_MIPS | ||
11 | -#elif defined(__MIPSEL__) && defined(__LP64__) | ||
12 | +#elif defined(__mips__) && defined(__LP64__) | ||
13 | #define OPENSSL_64_BIT | ||
14 | #define OPENSSL_MIPS64 | ||
15 | #elif defined(__riscv) | ||
diff --git a/meta-python/recipes-devtools/python/python3-grpcio_1.36.1.bb b/meta-python/recipes-devtools/python/python3-grpcio_1.36.1.bb index d374b54b34..3d875bf4ba 100644 --- a/meta-python/recipes-devtools/python/python3-grpcio_1.36.1.bb +++ b/meta-python/recipes-devtools/python/python3-grpcio_1.36.1.bb | |||
@@ -10,6 +10,8 @@ SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch" | |||
10 | SRC_URI_append_class-target = " file://ppc-boringssl-support.patch \ | 10 | SRC_URI_append_class-target = " file://ppc-boringssl-support.patch \ |
11 | file://riscv64_support.patch \ | 11 | file://riscv64_support.patch \ |
12 | file://boring_ssl.patch \ | 12 | file://boring_ssl.patch \ |
13 | file://mips_bigendian.patch \ | ||
14 | file://0001-absl-always-use-asm-sgidefs.h.patch \ | ||
13 | " | 15 | " |
14 | SRC_URI[sha256sum] = "a66ea59b20f3669df0f0c6a3bd57b985e5b2d1dcf3e4c29819bb8dc232d0fd38" | 16 | SRC_URI[sha256sum] = "a66ea59b20f3669df0f0c6a3bd57b985e5b2d1dcf3e4c29819bb8dc232d0fd38" |
15 | 17 | ||