diff options
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pylint/0001-pylint-remove-plugin-pickle-test.patch | 53 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch | 26 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb (renamed from meta-python/recipes-devtools/python/python3-pylint_2.17.4.bb) | 5 |
3 files changed, 2 insertions, 82 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pylint/0001-pylint-remove-plugin-pickle-test.patch b/meta-python/recipes-devtools/python/python3-pylint/0001-pylint-remove-plugin-pickle-test.patch deleted file mode 100644 index a7637a5ca6..0000000000 --- a/meta-python/recipes-devtools/python/python3-pylint/0001-pylint-remove-plugin-pickle-test.patch +++ /dev/null | |||
@@ -1,53 +0,0 @@ | |||
1 | From 341e19dd69d847f84859e85cabff5846e7da24c4 Mon Sep 17 00:00:00 2001 | ||
2 | From: Trevor Gamblin <tgamblin@baylibre.com> | ||
3 | Date: Mon, 15 May 2023 09:26:04 -0400 | ||
4 | Subject: [PATCH] pylint: remove plugin pickle test | ||
5 | |||
6 | Upstream-Status: Inappropriate (oe-specific) | ||
7 | |||
8 | Upstream uses an assertion in the removed test to state that the test | ||
9 | needs changing if the plugin loading succeeds. The same failure wasn't | ||
10 | seen when running the tests on the host with pytest, so disable it by | ||
11 | removing the test from the suite. | ||
12 | |||
13 | Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com> | ||
14 | --- | ||
15 | tests/test_check_parallel.py | 22 ---------------------- | ||
16 | 1 file changed, 22 deletions(-) | ||
17 | |||
18 | diff --git a/tests/test_check_parallel.py b/tests/test_check_parallel.py | ||
19 | index d56502eaf..34fec140f 100644 | ||
20 | --- a/tests/test_check_parallel.py | ||
21 | +++ b/tests/test_check_parallel.py | ||
22 | @@ -257,28 +257,6 @@ class TestCheckParallelFramework: | ||
23 | assert stats.statement == 18 | ||
24 | assert stats.warning == 0 | ||
25 | |||
26 | - def test_linter_with_unpickleable_plugins_is_pickleable(self) -> None: | ||
27 | - """The linter needs to be pickle-able in order to be passed between workers""" | ||
28 | - linter = PyLinter(reporter=Reporter()) | ||
29 | - # We load an extension that we know is not pickle-safe | ||
30 | - linter.load_plugin_modules(["pylint.extensions.overlapping_exceptions"]) | ||
31 | - try: | ||
32 | - dill.dumps(linter) | ||
33 | - raise AssertionError( | ||
34 | - "Plugins loaded were pickle-safe! This test needs altering" | ||
35 | - ) | ||
36 | - except (KeyError, TypeError, PickleError, NotImplementedError): | ||
37 | - pass | ||
38 | - | ||
39 | - # And expect this call to make it pickle-able | ||
40 | - linter.load_plugin_configuration() | ||
41 | - try: | ||
42 | - dill.dumps(linter) | ||
43 | - except KeyError as exc: | ||
44 | - raise AssertionError( | ||
45 | - "Cannot pickle linter when using non-pickleable plugin" | ||
46 | - ) from exc | ||
47 | - | ||
48 | def test_worker_check_sequential_checker(self) -> None: | ||
49 | """Same as test_worker_check_single_file_no_checkers with SequentialTestChecker.""" | ||
50 | linter = PyLinter(reporter=Reporter()) | ||
51 | -- | ||
52 | 2.40.1 | ||
53 | |||
diff --git a/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch b/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch deleted file mode 100644 index 7950e72077..0000000000 --- a/meta-python/recipes-devtools/python/python3-pylint/0001-pyproject.toml-Remove-hard-coded-dependencies.patch +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | From c5c415a240189ac6730ba95de0bb5883dfb53609 Mon Sep 17 00:00:00 2001 | ||
2 | From: Trevor Gamblin <tgamblin@baylibre.com> | ||
3 | Date: Mon, 1 May 2023 11:32:24 -0400 | ||
4 | Subject: [PATCH] pyproject.toml: Remove hard-coded dependencies | ||
5 | |||
6 | Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com> | ||
7 | --- | ||
8 | Upstream-Status: Pending | ||
9 | |||
10 | pyproject.toml | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/pyproject.toml b/pyproject.toml | ||
14 | index bd542646b..2c0ed9485 100644 | ||
15 | --- a/pyproject.toml | ||
16 | +++ b/pyproject.toml | ||
17 | @@ -1,5 +1,5 @@ | ||
18 | [build-system] | ||
19 | -requires = ["setuptools~=62.6", "wheel~=0.37.1"] | ||
20 | +requires = ["setuptools", "wheel"] | ||
21 | build-backend = "setuptools.build_meta" | ||
22 | |||
23 | [project] | ||
24 | -- | ||
25 | 2.40.0 | ||
26 | |||
diff --git a/meta-python/recipes-devtools/python/python3-pylint_2.17.4.bb b/meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb index 96fce2e048..413e6599db 100644 --- a/meta-python/recipes-devtools/python/python3-pylint_2.17.4.bb +++ b/meta-python/recipes-devtools/python/python3-pylint_3.0.0.bb | |||
@@ -6,10 +6,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=c107cf754550e65755c42985a5d4e9c9" | |||
6 | SRC_URI += " \ | 6 | SRC_URI += " \ |
7 | git://github.com/pylint-dev/pylint;branch=main;protocol=https \ | 7 | git://github.com/pylint-dev/pylint;branch=main;protocol=https \ |
8 | file://run-ptest \ | 8 | file://run-ptest \ |
9 | file://0001-pyproject.toml-Remove-hard-coded-dependencies.patch \ | ||
10 | file://0001-pylint-remove-plugin-pickle-test.patch \ | ||
11 | " | 9 | " |
12 | SRCREV ?= "fc34a4b6abe56f3ac07ca15d846b1c1955545f85" | 10 | SRCREV ?= "4a7ad5ea9f1c5a98ccf736578a00554be0da6dc7" |
13 | 11 | ||
14 | inherit python_setuptools_build_meta ptest | 12 | inherit python_setuptools_build_meta ptest |
15 | 13 | ||
@@ -47,5 +45,6 @@ S = "${WORKDIR}/git" | |||
47 | do_install_ptest() { | 45 | do_install_ptest() { |
48 | install -d ${D}${PTEST_PATH}/tests | 46 | install -d ${D}${PTEST_PATH}/tests |
49 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | 47 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
48 | install -Dm 0644 ${S}/tests/.pylint_primer_tests/.gitkeep ${D}${PTEST_PATH}/tests/.pylint_primer_tests/.gitkeep | ||
50 | sed -i 's#/usr/bin/python$#/usr/bin/python3#g' ${D}${PTEST_PATH}/tests/data/ascript | 49 | sed -i 's#/usr/bin/python$#/usr/bin/python3#g' ${D}${PTEST_PATH}/tests/data/ascript |
51 | } | 50 | } |