summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-argcomplete_1.12.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-argcomplete_1.12.0.bb b/meta-python/recipes-devtools/python/python3-argcomplete_1.12.0.bb
new file mode 100644
index 0000000000..dd749dd9eb
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-argcomplete_1.12.0.bb
@@ -0,0 +1,18 @@
1SUMMARY = "Argcomplete provides easy, extensible command line tab completion of arguments for your Python script."
2HOMEPAGE = "https://github.com/kislyuk/argcomplete"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=2ee41112a44fe7014dce33e26468ba93"
5
6SRC_URI[md5sum] = "47e2a3db821f57165be8f3d3ec1e5259"
7SRC_URI[sha256sum] = "2fbe5ed09fd2c1d727d4199feca96569a5b50d44c71b16da9c742201f7cc295c"
8
9PYPI_PACKAGE = "argcomplete"
10
11inherit pypi setuptools3
12
13RDEPENDS_${PN} += "\
14 ${PYTHON_PN}-core \
15"
16
17BBCLASSEXTEND = "native nativesdk"
18