summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-pexpect.inc23
-rw-r--r--meta-python/recipes-devtools/python/python3-pexpect_4.8.0.bb25
2 files changed, 24 insertions, 24 deletions
diff --git a/meta-python/recipes-devtools/python/python-pexpect.inc b/meta-python/recipes-devtools/python/python-pexpect.inc
deleted file mode 100644
index c6230b2b5d..0000000000
--- a/meta-python/recipes-devtools/python/python-pexpect.inc
+++ /dev/null
@@ -1,23 +0,0 @@
1SUMMARY = "A Pure Python Expect like Module for Python"
2HOMEPAGE = "http://pexpect.readthedocs.org/"
3SECTION = "devel/python"
4LICENSE = "ISC"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1c7a725251880af8c6a148181665385b"
6
7SRC_URI += "file://0001-FSM.py-change-shebang-from-python-to-python3.patch"
8
9SRC_URI[md5sum] = "153eb25184249d6a85fde9acf4804085"
10SRC_URI[sha256sum] = "fc65a43959d153d0114afe13997d439c22823a27cefceb5ff35c2178c6784c0c"
11
12UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/pexpect"
13
14RDEPENDS_${PN} = "\
15 ${PYTHON_PN}-core \
16 ${PYTHON_PN}-io \
17 ${PYTHON_PN}-terminal \
18 ${PYTHON_PN}-resource \
19 ${PYTHON_PN}-fcntl \
20 ${PYTHON_PN}-ptyprocess \
21"
22
23BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-pexpect_4.8.0.bb b/meta-python/recipes-devtools/python/python3-pexpect_4.8.0.bb
index cf39233a3a..99e1f199fa 100644
--- a/meta-python/recipes-devtools/python/python3-pexpect_4.8.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pexpect_4.8.0.bb
@@ -1,2 +1,25 @@
1require python-pexpect.inc 1SUMMARY = "A Pure Python Expect like Module for Python"
2HOMEPAGE = "http://pexpect.readthedocs.org/"
3SECTION = "devel/python"
4LICENSE = "ISC"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1c7a725251880af8c6a148181665385b"
6
7SRC_URI += "file://0001-FSM.py-change-shebang-from-python-to-python3.patch"
8
9SRC_URI[md5sum] = "153eb25184249d6a85fde9acf4804085"
10SRC_URI[sha256sum] = "fc65a43959d153d0114afe13997d439c22823a27cefceb5ff35c2178c6784c0c"
11
2inherit pypi setuptools3 12inherit pypi setuptools3
13
14UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/pexpect"
15
16RDEPENDS_${PN} = "\
17 ${PYTHON_PN}-core \
18 ${PYTHON_PN}-io \
19 ${PYTHON_PN}-terminal \
20 ${PYTHON_PN}-resource \
21 ${PYTHON_PN}-fcntl \
22 ${PYTHON_PN}-ptyprocess \
23"
24
25BBCLASSEXTEND = "native nativesdk"