summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-tomlkit/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-tomlkit_0.12.3.bb7
2 files changed, 5 insertions, 4 deletions
diff --git a/meta-python/recipes-devtools/python/python3-tomlkit/run-ptest b/meta-python/recipes-devtools/python/python3-tomlkit/run-ptest
index b63c4de0d9..8d2017d39c 100644
--- a/meta-python/recipes-devtools/python/python3-tomlkit/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-tomlkit/run-ptest
@@ -1,3 +1,3 @@
1#!/bin/sh 1#!/bin/sh
2 2
3pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' 3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-tomlkit_0.12.3.bb b/meta-python/recipes-devtools/python/python3-tomlkit_0.12.3.bb
index 89acd77770..d4162a110b 100644
--- a/meta-python/recipes-devtools/python/python3-tomlkit_0.12.3.bb
+++ b/meta-python/recipes-devtools/python/python3-tomlkit_0.12.3.bb
@@ -18,9 +18,10 @@ RDEPENDS:${PN} += " \
18" 18"
19 19
20RDEPENDS:${PN}-ptest += " \ 20RDEPENDS:${PN}-ptest += " \
21 ${PYTHON_PN}-poetry-core \ 21 python3-poetry-core \
22 ${PYTHON_PN}-pytest \ 22 python3-pytest \
23 ${PYTHON_PN}-pyyaml \ 23 python3-pyyaml \
24 python3-unittest-automake-output \
24" 25"
25 26
26do_install_ptest() { 27do_install_ptest() {