summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-dbus-fast/0001-pyproject.toml-Remove-upper-version-constraint-for-C.patch33
-rw-r--r--meta-python/recipes-devtools/python/python3-dbus-fast_2.44.1.bb1
2 files changed, 34 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dbus-fast/0001-pyproject.toml-Remove-upper-version-constraint-for-C.patch b/meta-python/recipes-devtools/python/python3-dbus-fast/0001-pyproject.toml-Remove-upper-version-constraint-for-C.patch
new file mode 100644
index 0000000000..fb8f4df4a6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-dbus-fast/0001-pyproject.toml-Remove-upper-version-constraint-for-C.patch
@@ -0,0 +1,33 @@
1From 85189fb66d3abb2645605f8a3c14d8152ef755fe Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 18 May 2025 10:24:19 -0700
4Subject: [PATCH] pyproject.toml: Remove upper version constraint for Cython
5
6Upstream-Status: Pending
7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8---
9 pyproject.toml | 4 ++--
10 1 file changed, 2 insertions(+), 2 deletions(-)
11
12diff --git a/pyproject.toml b/pyproject.toml
13index e22ea42..f670d3d 100644
14--- a/pyproject.toml
15+++ b/pyproject.toml
16@@ -50,7 +50,7 @@ pytest-cov = ">=3,<7"
17 pytest-asyncio = ">=0.19,<0.27"
18 pycairo = "^1.21.0"
19 PyGObject = {version = ">=3.50,<3.51", python = "<4"}
20-Cython = ">=3,<3.1.0"
21+Cython = ">=3"
22 setuptools = ">=65.4.1,<79.0.0"
23 pytest-timeout = "^2.1.0"
24 pytest-codspeed = "^3.1.1"
25@@ -104,7 +104,7 @@ module = "docs.*"
26 ignore_errors = true
27
28 [build-system]
29-requires = ['setuptools>=65.4.1', 'wheel', 'Cython>=3,<3.1.0', "poetry-core>=1.0.0"]
30+requires = ['setuptools>=65.4.1', 'wheel', 'Cython>=3', "poetry-core>=1.0.0"]
31 build-backend = "poetry.core.masonry.api"
32
33 [tool.ruff]
diff --git a/meta-python/recipes-devtools/python/python3-dbus-fast_2.44.1.bb b/meta-python/recipes-devtools/python/python3-dbus-fast_2.44.1.bb
index 95f1eafebd..f827d21bb2 100644
--- a/meta-python/recipes-devtools/python/python3-dbus-fast_2.44.1.bb
+++ b/meta-python/recipes-devtools/python/python3-dbus-fast_2.44.1.bb
@@ -3,6 +3,7 @@ HOMEPAGE = "https://github.com/bluetooth-devices/dbus-fast"
3LICENSE = "MIT" 3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=729e372b5ea0168438e4fd4a00a04947" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=729e372b5ea0168438e4fd4a00a04947"
5 5
6SRC_URI += "file://0001-pyproject.toml-Remove-upper-version-constraint-for-C.patch"
6SRC_URI[sha256sum] = "b027e96c39ed5622bb54d811dcdbbe9d9d6edec3454808a85a1ceb1867d9e25c" 7SRC_URI[sha256sum] = "b027e96c39ed5622bb54d811dcdbbe9d9d6edec3454808a85a1ceb1867d9e25c"
7 8
8PYPI_PACKAGE = "dbus_fast" 9PYPI_PACKAGE = "dbus_fast"