summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-scrypt/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-scrypt_0.8.27.bb13
2 files changed, 2 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python3-scrypt/run-ptest b/meta-python/recipes-devtools/python/python3-scrypt/run-ptest
deleted file mode 100644
index 8d2017d39c..0000000000
--- a/meta-python/recipes-devtools/python/python3-scrypt/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-scrypt_0.8.27.bb b/meta-python/recipes-devtools/python/python3-scrypt_0.8.27.bb
index a3254de07d..02f1da8f59 100644
--- a/meta-python/recipes-devtools/python/python3-scrypt_0.8.27.bb
+++ b/meta-python/recipes-devtools/python/python3-scrypt_0.8.27.bb
@@ -7,22 +7,13 @@ SRC_URI += "file://0001-py-scrypt-remove-the-hard-coded-include-paths.patch"
7 7
8SRC_URI[sha256sum] = "a7b637848ed518c1ea2b31a9ecaaa3f49616598d8442de8706cf1f01fbabf0a7" 8SRC_URI[sha256sum] = "a7b637848ed518c1ea2b31a9ecaaa3f49616598d8442de8706cf1f01fbabf0a7"
9 9
10inherit pypi ptest setuptools3 dos2unix 10inherit pypi ptest-python-pytest setuptools3 dos2unix
11
12SRC_URI += " \
13 file://run-ptest \
14"
15
16RDEPENDS:${PN}-ptest += " \
17 python3-pytest \
18 python3-unittest-automake-output \
19"
20 11
21RDEPENDS:${PN} += " \ 12RDEPENDS:${PN} += " \
22 python3-ctypes \ 13 python3-ctypes \
23" 14"
24 15
25do_install_ptest() { 16do_install_ptest:append() {
26 install -d ${D}${PTEST_PATH}/tests 17 install -d ${D}${PTEST_PATH}/tests
27 cp -rf ${S}/scrypt/tests/* ${D}${PTEST_PATH}/tests/ 18 cp -rf ${S}/scrypt/tests/* ${D}${PTEST_PATH}/tests/
28} 19}