summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-meson-python_0.13.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-meson-python_0.13.1.bb b/meta-python/recipes-devtools/python/python3-meson-python_0.13.1.bb
new file mode 100644
index 0000000000..6b9ff24f2a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-meson-python_0.13.1.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Meson Python build backend (PEP 517)"
2HOMEPAGE = "https://github.com/mesonbuild/meson-python"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=d580b27e67cc0892a5b005b0be114b60"
5
6DEPENDS = " \
7 meson-native ninja-native patchelf-native \
8 python3-pyproject-metadata-native \
9"
10
11PYPI_PACKAGE = "meson_python"
12
13inherit pypi python_mesonpy
14SRC_URI[sha256sum] = "63b3170001425c42fa4cfedadb9051cbd28925ff8eed7c40d36ba0099e3c7618"
15
16DEPENDS:remove:class-native = "python3-meson-python-native"
17
18RDEPENDS:${PN} = " \
19 meson ninja patchelf \
20 python3-pyproject-metadata \
21"
22
23BBCLASSEXTEND = "native nativesdk"