diff options
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pillow/0001-explicitly-set-compile-options.patch | 19 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pillow_7.2.0.bb (renamed from meta-python/recipes-devtools/python/python3-pillow_6.2.1.bb) | 6 |
2 files changed, 14 insertions, 11 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pillow/0001-explicitly-set-compile-options.patch b/meta-python/recipes-devtools/python/python3-pillow/0001-explicitly-set-compile-options.patch index 35aee42145..005fea5c66 100644 --- a/meta-python/recipes-devtools/python/python3-pillow/0001-explicitly-set-compile-options.patch +++ b/meta-python/recipes-devtools/python/python3-pillow/0001-explicitly-set-compile-options.patch | |||
@@ -1,6 +1,6 @@ | |||
1 | From 862a981ce462cd83a99e3db9faeeda1f8c64983f Mon Sep 17 00:00:00 2001 | 1 | From 27bfa4028453dc79a72569823e97da8fd1994ffc Mon Sep 17 00:00:00 2001 |
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | 2 | From: Leon Anavi <leon.anavi@konsulko.com> |
3 | Date: Mon, 18 Mar 2019 23:23:55 -0400 | 3 | Date: Tue, 1 Sep 2020 11:53:53 +0000 |
4 | Subject: [PATCH] explicitly set compile options | 4 | Subject: [PATCH] explicitly set compile options |
5 | 5 | ||
6 | OE does not support to install egg package, so | 6 | OE does not support to install egg package, so |
@@ -10,19 +10,19 @@ explicitly set build_ext options for oe-core's | |||
10 | Upstream-Status: Inappropriate [oe specific] | 10 | Upstream-Status: Inappropriate [oe specific] |
11 | 11 | ||
12 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | 12 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> |
13 | 13 | Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> | |
14 | --- | 14 | --- |
15 | setup.cfg | 12 ++++++++++++ | 15 | setup.cfg | 12 ++++++++++++ |
16 | 1 file changed, 12 insertions(+) | 16 | 1 file changed, 12 insertions(+) |
17 | 17 | ||
18 | diff --git a/setup.cfg b/setup.cfg | 18 | diff --git a/setup.cfg b/setup.cfg |
19 | index 1c6ebc84..1ccc3d69 100644 | 19 | index 19979cf7..ed27dfe1 100644 |
20 | --- a/setup.cfg | 20 | --- a/setup.cfg |
21 | +++ b/setup.cfg | 21 | +++ b/setup.cfg |
22 | @@ -13,3 +13,15 @@ multi_line_output = 3 | 22 | @@ -11,3 +11,15 @@ multi_line_output = 3 |
23 | |||
24 | [tool:pytest] | 23 | [tool:pytest] |
25 | addopts = -rs | 24 | addopts = -ra --color=yes |
25 | testpaths = Tests | ||
26 | + | 26 | + |
27 | +[build_ext] | 27 | +[build_ext] |
28 | +disable-platform-guessing = 1 | 28 | +disable-platform-guessing = 1 |
@@ -35,3 +35,6 @@ index 1c6ebc84..1ccc3d69 100644 | |||
35 | +disable-webp = 1 | 35 | +disable-webp = 1 |
36 | +disable-webpmux = 1 | 36 | +disable-webpmux = 1 |
37 | +disable-imagequant = 1 | 37 | +disable-imagequant = 1 |
38 | -- | ||
39 | 2.17.1 | ||
40 | |||
diff --git a/meta-python/recipes-devtools/python/python3-pillow_6.2.1.bb b/meta-python/recipes-devtools/python/python3-pillow_7.2.0.bb index a383a3ff91..13cab43008 100644 --- a/meta-python/recipes-devtools/python/python3-pillow_6.2.1.bb +++ b/meta-python/recipes-devtools/python/python3-pillow_7.2.0.bb | |||
@@ -3,13 +3,13 @@ Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and \ | |||
3 | Contributors." | 3 | Contributors." |
4 | HOMEPAGE = "https://pillow.readthedocs.io" | 4 | HOMEPAGE = "https://pillow.readthedocs.io" |
5 | LICENSE = "MIT" | 5 | LICENSE = "MIT" |
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=55c0f320370091249c1755c0d2b48e89" | 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=ea2dc3f5611e69058503d4b940049d03" |
7 | 7 | ||
8 | SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=6.2.x \ | 8 | SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=7.2.x \ |
9 | file://0001-support-cross-compiling.patch \ | 9 | file://0001-support-cross-compiling.patch \ |
10 | file://0001-explicitly-set-compile-options.patch \ | 10 | file://0001-explicitly-set-compile-options.patch \ |
11 | " | 11 | " |
12 | SRCREV ?= "6e0f07bbe38def22d36ee176b2efd9ea74b453a6" | 12 | SRCREV ?= "2bd74943fb9f320def6c066e732b701d1c15f677" |
13 | 13 | ||
14 | 14 | ||
15 | inherit setuptools3 | 15 | inherit setuptools3 |