summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-charset-normalizer/0001-pyproject.toml-Relax-version-for-mypy.patch25
-rw-r--r--meta-python/recipes-devtools/python/python3-charset-normalizer_3.4.1.bb7
2 files changed, 31 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-charset-normalizer/0001-pyproject.toml-Relax-version-for-mypy.patch b/meta-python/recipes-devtools/python/python3-charset-normalizer/0001-pyproject.toml-Relax-version-for-mypy.patch
new file mode 100644
index 0000000000..d544caaa17
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-charset-normalizer/0001-pyproject.toml-Relax-version-for-mypy.patch
@@ -0,0 +1,25 @@
1From 57b626d6d8c247c9203dde51a988b9401abe065c Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 9 Apr 2025 23:44:44 -0700
4Subject: [PATCH] pyproject.toml: Relax version for mypy
5
6It asks for mypy <= 1.14.0 but we have 1.15.x
7already in meta-python
8
9Upstream-Status: Pending
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 pyproject.toml | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/pyproject.toml b/pyproject.toml
16index bbb8227..ad42715 100644
17--- a/pyproject.toml
18+++ b/pyproject.toml
19@@ -1,5 +1,5 @@
20 [build-system]
21-requires = ["setuptools", "setuptools-scm", "mypy>=1.4.1,<=1.14.0"]
22+requires = ["setuptools", "setuptools-scm", "mypy>=1.4.1,<=1.16.0"]
23 build-backend = "setuptools.build_meta"
24
25 [project]
diff --git a/meta-python/recipes-devtools/python/python3-charset-normalizer_3.4.1.bb b/meta-python/recipes-devtools/python/python3-charset-normalizer_3.4.1.bb
index b13524c227..4f9b09ef93 100644
--- a/meta-python/recipes-devtools/python/python3-charset-normalizer_3.4.1.bb
+++ b/meta-python/recipes-devtools/python/python3-charset-normalizer_3.4.1.bb
@@ -3,9 +3,12 @@ HOMEPAGE = "https://github.com/ousret/charset_normalizer"
3LICENSE = "MIT" 3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=48178f3fc1374ad7e830412f812bde05" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=48178f3fc1374ad7e830412f812bde05"
5 5
6SRC_URI += "file://0001-pyproject.toml-Relax-version-for-mypy.patch"
6SRC_URI[sha256sum] = "44251f18cd68a75b56585dd00dae26183e102cd5e0f9f1466e6df5da2ed64ea3" 7SRC_URI[sha256sum] = "44251f18cd68a75b56585dd00dae26183e102cd5e0f9f1466e6df5da2ed64ea3"
7 8
8inherit pypi setuptools3 9DEPENDS += "python3-setuptools-scm-native python3-mypy-native"
10
11inherit pypi python_setuptools_build_meta ptest-python-pytest
9 12
10PYPI_PACKAGE = "charset_normalizer" 13PYPI_PACKAGE = "charset_normalizer"
11UPSTREAM_CHECK_PYPI_PACKAGE = "${PYPI_PACKAGE}" 14UPSTREAM_CHECK_PYPI_PACKAGE = "${PYPI_PACKAGE}"
@@ -13,8 +16,10 @@ UPSTREAM_CHECK_PYPI_PACKAGE = "${PYPI_PACKAGE}"
13RDEPENDS:${PN} += " \ 16RDEPENDS:${PN} += " \
14 python3-core \ 17 python3-core \
15 python3-logging \ 18 python3-logging \
19 python3-mypy \
16 python3-codecs \ 20 python3-codecs \
17 python3-json \ 21 python3-json \
18" 22"
19 23
24RDEPENDS:${PN}-ptest:append:libc-glibc = " glibc-charmap-gb18030 glibc-charmaps"
20BBCLASSEXTEND = "native nativesdk" 25BBCLASSEXTEND = "native nativesdk"