diff options
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-pymongo.inc | 29 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pymongo_3.10.1.bb | 31 |
2 files changed, 30 insertions, 30 deletions
diff --git a/meta-python/recipes-devtools/python/python-pymongo.inc b/meta-python/recipes-devtools/python/python-pymongo.inc deleted file mode 100644 index 2b9794f9c4..0000000000 --- a/meta-python/recipes-devtools/python/python-pymongo.inc +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | SUMMARY = "Python driver for MongoDB <http://www.mongodb.org>" | ||
2 | DESCRIPTION = "\ | ||
3 | The PyMongo distribution contains tools for interacting with MongoDB \ | ||
4 | database from Python. The bson package is an implementation of the BSON \ | ||
5 | format for Python. The pymongo package is a native Python driver for \ | ||
6 | MongoDB. The gridfs package is a gridfs implementation on top of pymongo." | ||
7 | HOMEPAGE = "http://github.com/mongodb/mongo-python-driver" | ||
8 | LICENSE = "Apache-2.0" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" | ||
10 | |||
11 | SRC_URI[md5sum] = "e31b9c0190c9eaf1f792d0277b2a8ebe" | ||
12 | SRC_URI[sha256sum] = "993257f6ca3cde55332af1f62af3e04ca89ce63c08b56a387cdd46136c72f2fa" | ||
13 | |||
14 | PACKAGES =+ "${PYTHON_PN}-bson" | ||
15 | |||
16 | FILES_${PYTHON_PN}-bson = "${PYTHON_SITEPACKAGES_DIR}/bson/*" | ||
17 | |||
18 | RDEPENDS_${PYTHON_PN}-bson += " \ | ||
19 | ${PYTHON_PN}-datetime \ | ||
20 | ${PYTHON_PN}-json \ | ||
21 | ${PYTHON_PN}-netclient \ | ||
22 | ${PYTHON_PN}-numbers \ | ||
23 | ${PYTHON_PN}-threading \ | ||
24 | " | ||
25 | |||
26 | RDEPENDS_${PN} += " \ | ||
27 | ${PYTHON_PN}-bson \ | ||
28 | ${PYTHON_PN}-pprint \ | ||
29 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-pymongo_3.10.1.bb b/meta-python/recipes-devtools/python/python3-pymongo_3.10.1.bb index 5164b186bf..f69ca53cf5 100644 --- a/meta-python/recipes-devtools/python/python3-pymongo_3.10.1.bb +++ b/meta-python/recipes-devtools/python/python3-pymongo_3.10.1.bb | |||
@@ -1,2 +1,31 @@ | |||
1 | SUMMARY = "Python driver for MongoDB <http://www.mongodb.org>" | ||
2 | DESCRIPTION = "\ | ||
3 | The PyMongo distribution contains tools for interacting with MongoDB \ | ||
4 | database from Python. The bson package is an implementation of the BSON \ | ||
5 | format for Python. The pymongo package is a native Python driver for \ | ||
6 | MongoDB. The gridfs package is a gridfs implementation on top of pymongo." | ||
7 | HOMEPAGE = "http://github.com/mongodb/mongo-python-driver" | ||
8 | LICENSE = "Apache-2.0" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" | ||
10 | |||
11 | SRC_URI[md5sum] = "e31b9c0190c9eaf1f792d0277b2a8ebe" | ||
12 | SRC_URI[sha256sum] = "993257f6ca3cde55332af1f62af3e04ca89ce63c08b56a387cdd46136c72f2fa" | ||
13 | |||
1 | inherit pypi setuptools3 | 14 | inherit pypi setuptools3 |
2 | require python-pymongo.inc | 15 | |
16 | PACKAGES =+ "${PYTHON_PN}-bson" | ||
17 | |||
18 | FILES_${PYTHON_PN}-bson = "${PYTHON_SITEPACKAGES_DIR}/bson/*" | ||
19 | |||
20 | RDEPENDS_${PYTHON_PN}-bson += " \ | ||
21 | ${PYTHON_PN}-datetime \ | ||
22 | ${PYTHON_PN}-json \ | ||
23 | ${PYTHON_PN}-netclient \ | ||
24 | ${PYTHON_PN}-numbers \ | ||
25 | ${PYTHON_PN}-threading \ | ||
26 | " | ||
27 | |||
28 | RDEPENDS_${PN} += " \ | ||
29 | ${PYTHON_PN}-bson \ | ||
30 | ${PYTHON_PN}-pprint \ | ||
31 | " | ||