diff options
Diffstat (limited to 'meta-python/recipes-devtools/python')
3 files changed, 19 insertions, 9 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytest.inc b/meta-python/recipes-devtools/python/python-pytest.inc new file mode 100644 index 0000000000..4877358f2e --- /dev/null +++ b/meta-python/recipes-devtools/python/python-pytest.inc | |||
@@ -0,0 +1,16 @@ | |||
1 | SUMMARY = "Simple powerful teting with python" | ||
2 | LICENSE = "MIT" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d8a5609608d9a5a180705b0fa298ae01" | ||
4 | |||
5 | SRC_URI[md5sum] = "05165740ea50928e4e971378630163ec" | ||
6 | SRC_URI[sha256sum] = "0d48d27a127644fbe7c8158157e08b35f8255045d4476df694b91eb3a8147e65" | ||
7 | |||
8 | RDEPENDS_${PN} = " \ | ||
9 | ${PYTHON_PN}-argparse \ | ||
10 | ${PYTHON_PN}-debugger \ | ||
11 | ${PYTHON_PN}-json \ | ||
12 | ${PYTHON_PN}-py \ | ||
13 | ${PYTHON_PN}-setuptools \ | ||
14 | " | ||
15 | |||
16 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python-pytest_2.9.1.bb b/meta-python/recipes-devtools/python/python-pytest_2.9.1.bb index e21c4f45a9..d322f09b24 100644 --- a/meta-python/recipes-devtools/python/python-pytest_2.9.1.bb +++ b/meta-python/recipes-devtools/python/python-pytest_2.9.1.bb | |||
@@ -1,10 +1,2 @@ | |||
1 | SUMMARY = "Simple powerful teting with Python" | ||
2 | LICENSE = "MIT" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d8a5609608d9a5a180705b0fa298ae01" | ||
4 | |||
5 | SRC_URI[md5sum] = "05165740ea50928e4e971378630163ec" | ||
6 | SRC_URI[sha256sum] = "0d48d27a127644fbe7c8158157e08b35f8255045d4476df694b91eb3a8147e65" | ||
7 | |||
8 | RDEPENDS_${PN} = "python-py python-setuptools python-argparse python-debugger python-json" | ||
9 | |||
10 | inherit pypi setuptools | 1 | inherit pypi setuptools |
2 | require python-pytest.inc | ||
diff --git a/meta-python/recipes-devtools/python/python3-pytest_2.9.1.bb b/meta-python/recipes-devtools/python/python3-pytest_2.9.1.bb new file mode 100644 index 0000000000..466cfa8253 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pytest_2.9.1.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit pypi setuptools3 | ||
2 | require python-pytest.inc | ||