diff options
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-grpcio/0001-zlib-Include-unistd.h-for-open-close-C-APIs.patch | 24 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-grpcio_1.69.0.bb | 4 |
2 files changed, 2 insertions, 26 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio/0001-zlib-Include-unistd.h-for-open-close-C-APIs.patch b/meta-python/recipes-devtools/python/python3-grpcio/0001-zlib-Include-unistd.h-for-open-close-C-APIs.patch deleted file mode 100644 index 584723e6d1..0000000000 --- a/meta-python/recipes-devtools/python/python3-grpcio/0001-zlib-Include-unistd.h-for-open-close-C-APIs.patch +++ /dev/null | |||
@@ -1,24 +0,0 @@ | |||
1 | From f84421d8ee06890e2c98c0f7c9ec6c73f88e77c3 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sun, 12 Feb 2023 21:25:04 -0800 | ||
4 | Subject: [PATCH] zlib: Include unistd.h for open/close C APIs | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | |||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | --- | ||
10 | third_party/zlib/gzguts.h | 1 + | ||
11 | 1 file changed, 1 insertion(+) | ||
12 | |||
13 | diff --git a/third_party/zlib/gzguts.h b/third_party/zlib/gzguts.h | ||
14 | index f937504..341a68d 100644 | ||
15 | --- a/third_party/zlib/gzguts.h | ||
16 | +++ b/third_party/zlib/gzguts.h | ||
17 | @@ -18,6 +18,7 @@ | ||
18 | #endif | ||
19 | |||
20 | #include <stdio.h> | ||
21 | +#include <unistd.h> | ||
22 | #include "zlib.h" | ||
23 | #ifdef STDC | ||
24 | # include <string.h> | ||
diff --git a/meta-python/recipes-devtools/python/python3-grpcio_1.69.0.bb b/meta-python/recipes-devtools/python/python3-grpcio_1.69.0.bb index 32d4fbc22a..d621f840f1 100644 --- a/meta-python/recipes-devtools/python/python3-grpcio_1.69.0.bb +++ b/meta-python/recipes-devtools/python/python3-grpcio_1.69.0.bb | |||
@@ -4,12 +4,11 @@ SECTION = "devel/python" | |||
4 | LICENSE = "Apache-2.0 & BSD-3-Clause" | 4 | LICENSE = "Apache-2.0 & BSD-3-Clause" |
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=731e401b36f8077ae0c134b59be5c906" | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=731e401b36f8077ae0c134b59be5c906" |
6 | 6 | ||
7 | DEPENDS += "openssl python3-protobuf" | 7 | DEPENDS += "openssl python3-protobuf zlib" |
8 | 8 | ||
9 | SRC_URI += "file://0001-python-enable-unbundled-cross-compilation.patch \ | 9 | SRC_URI += "file://0001-python-enable-unbundled-cross-compilation.patch \ |
10 | file://0001-Include-missing-cstdint-header.patch \ | 10 | file://0001-Include-missing-cstdint-header.patch \ |
11 | file://abseil-ppc-fixes.patch \ | 11 | file://abseil-ppc-fixes.patch \ |
12 | file://0001-zlib-Include-unistd.h-for-open-close-C-APIs.patch \ | ||
13 | " | 12 | " |
14 | SRC_URI[sha256sum] = "936fa44241b5379c5afc344e1260d467bee495747eaf478de825bab2791da6f5" | 13 | SRC_URI[sha256sum] = "936fa44241b5379c5afc344e1260d467bee495747eaf478de825bab2791da6f5" |
15 | 14 | ||
@@ -21,6 +20,7 @@ inherit pypi | |||
21 | CFLAGS:append:libc-musl = " -D_LARGEFILE64_SOURCE" | 20 | CFLAGS:append:libc-musl = " -D_LARGEFILE64_SOURCE" |
22 | 21 | ||
23 | export GRPC_PYTHON_BUILD_SYSTEM_OPENSSL = "1" | 22 | export GRPC_PYTHON_BUILD_SYSTEM_OPENSSL = "1" |
23 | export GRPC_PYTHON_BUILD_SYSTEM_ZLIB = "1" | ||
24 | 24 | ||
25 | GRPC_CFLAGS ?= "" | 25 | GRPC_CFLAGS ?= "" |
26 | GRPC_CFLAGS:append:toolchain-clang = " -fvisibility=hidden -fno-wrapv -fno-exceptions" | 26 | GRPC_CFLAGS:append:toolchain-clang = " -fvisibility=hidden -fno-wrapv -fno-exceptions" |