diff options
Diffstat (limited to 'meta-python/recipes-devtools/python')
3 files changed, 43 insertions, 23 deletions
diff --git a/meta-python/recipes-devtools/python/python3-marshmallow/run-ptest b/meta-python/recipes-devtools/python/python3-marshmallow/run-ptest new file mode 100644 index 0000000000..8d2017d39c --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-marshmallow/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest --automake | ||
diff --git a/meta-python/recipes-devtools/python/python3-marshmallow_3.20.2.bb b/meta-python/recipes-devtools/python/python3-marshmallow_3.20.2.bb deleted file mode 100644 index c08aec5bec..0000000000 --- a/meta-python/recipes-devtools/python/python3-marshmallow_3.20.2.bb +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | SUMMARY = "Simplified object serialization in python" | ||
2 | DESCRIPTION = "Marshmallow is an ORM/ODM/framework-agnostic library for converting complex datatypes, such as objects, to and from native Python datatypes." | ||
3 | HOMEPAGE = "https://github.com/marshmallow-code/marshmallow" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "\ | ||
6 | file://LICENSE;md5=653847350fed2e0e7b02791a35b98d59 \ | ||
7 | file://docs/license.rst;md5=13da439ad060419fb7cf364523017cfb" | ||
8 | |||
9 | SRC_URI[sha256sum] = "4c1daff273513dc5eb24b219a8035559dc573c8f322558ef85f5438ddd1236dd" | ||
10 | |||
11 | inherit setuptools3 pypi | ||
12 | |||
13 | PIP_INSTALL_PACKAGE = "marshmallow" | ||
14 | |||
15 | RDEPENDS:${PN} += " \ | ||
16 | python3-core \ | ||
17 | python3-datetime \ | ||
18 | python3-netclient \ | ||
19 | python3-numbers \ | ||
20 | python3-json \ | ||
21 | python3-pprint \ | ||
22 | python3-packaging \ | ||
23 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-marshmallow_3.21.1.bb b/meta-python/recipes-devtools/python/python3-marshmallow_3.21.1.bb new file mode 100644 index 0000000000..5a0a79a541 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-marshmallow_3.21.1.bb | |||
@@ -0,0 +1,40 @@ | |||
1 | SUMMARY = "Simplified object serialization in python" | ||
2 | DESCRIPTION = "Marshmallow is an ORM/ODM/framework-agnostic library for converting complex datatypes, such as objects, to and from native Python datatypes." | ||
3 | HOMEPAGE = "https://github.com/marshmallow-code/marshmallow" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "\ | ||
6 | file://LICENSE;md5=27586b20700d7544c06933afe56f7df4 \ | ||
7 | file://docs/license.rst;md5=13da439ad060419fb7cf364523017cfb" | ||
8 | |||
9 | SRC_URI[sha256sum] = "4e65e9e0d80fc9e609574b9983cf32579f305c718afb30d7233ab818571768c3" | ||
10 | |||
11 | inherit python_flit_core pypi ptest | ||
12 | |||
13 | PIP_INSTALL_PACKAGE = "marshmallow" | ||
14 | |||
15 | SRC_URI += " \ | ||
16 | file://run-ptest \ | ||
17 | " | ||
18 | |||
19 | RDEPENDS:${PN}-ptest += " \ | ||
20 | python3-pytest \ | ||
21 | python3-pytz \ | ||
22 | python3-simplejson \ | ||
23 | python3-unittest-automake-output \ | ||
24 | " | ||
25 | |||
26 | do_install_ptest() { | ||
27 | install -d ${D}${PTEST_PATH}/tests | ||
28 | rm -rf ${S}/tests/mypy_test_cases | ||
29 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
30 | } | ||
31 | |||
32 | RDEPENDS:${PN} += " \ | ||
33 | python3-compression \ | ||
34 | python3-datetime \ | ||
35 | python3-email \ | ||
36 | python3-json \ | ||
37 | python3-numbers \ | ||
38 | python3-pprint \ | ||
39 | python3-packaging \ | ||
40 | " | ||