summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-inline-snapshot_0.14.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-inline-snapshot_0.14.0.bb b/meta-python/recipes-devtools/python/python3-inline-snapshot_0.14.0.bb
new file mode 100644
index 0000000000..8ccd4ba8d2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-inline-snapshot_0.14.0.bb
@@ -0,0 +1,20 @@
1SUMMARY = "golden master/snapshot/approval testing library which puts the values right into your source code"
2HOMEPAGE = "https://15r10nk.github.io/inline-snapshot"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=7a35eb90dfdf03953dd2074d0fdba1d4"
5
6DEPENDS = "python3-hatchling-native"
7SRC_URI[sha256sum] = "54fdf7831055d06a2423054875d640102865a164cc8291a8086e44dd9b4fd316"
8
9inherit pypi python_hatchling
10
11PYPI_PACKAGE = "inline_snapshot"
12
13RDEPENDS:${PN} = "python3-asttokens \
14 python3-black \
15 python3-click \
16 python3-executing \
17 python3-rich \
18 python3-tomli \
19 python3-typing-extensions \
20 "