summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-rfc3339-validator.inc25
-rw-r--r--meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.1.bb27
2 files changed, 25 insertions, 27 deletions
diff --git a/meta-python/recipes-devtools/python/python-rfc3339-validator.inc b/meta-python/recipes-devtools/python/python-rfc3339-validator.inc
deleted file mode 100644
index 3da082984d..0000000000
--- a/meta-python/recipes-devtools/python/python-rfc3339-validator.inc
+++ /dev/null
@@ -1,25 +0,0 @@
1SUMMARY = "A pure python RFC3339 validator"
2HOMEPAGE = "https://github.com/naimetti/rfc3339-validator"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=a21b13b5a996f08f7e0b088aa38ce9c6"
5
6FILESEXTRAPATHS_prepend := "${THISDIR}/python-rfc3339-validator:"
7
8SRC_URI[md5sum] = "9d8899041d83f98180bddd8b62ee7e99"
9SRC_URI[sha256sum] = "20a600d01fbb1f793cbb6f4ec4ebb2104f4c9e80d74d5f78350b63ecc6cccd08"
10
11PYPI_PACKAGE = "rfc3339_validator"
12
13inherit pypi
14
15SRC_URI_append = " \
16 file://0001-setup.py-move-pytest-runner-to-test_requirements.patch \
17"
18
19RDEPENDS_${PN} += "\
20 ${PYTHON_PN}-core \
21 ${PYTHON_PN}-datetime \
22 ${PYTHON_PN}-six \
23"
24
25BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.1.bb b/meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.1.bb
index f4ee8fedaa..1f5d91d3b2 100644
--- a/meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.1.bb
+++ b/meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.1.bb
@@ -1,2 +1,25 @@
1inherit setuptools3 1SUMMARY = "A pure python RFC3339 validator"
2require python-rfc3339-validator.inc \ No newline at end of file 2HOMEPAGE = "https://github.com/naimetti/rfc3339-validator"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=a21b13b5a996f08f7e0b088aa38ce9c6"
5
6FILESEXTRAPATHS_prepend := "${THISDIR}/python-rfc3339-validator:"
7
8SRC_URI[md5sum] = "9d8899041d83f98180bddd8b62ee7e99"
9SRC_URI[sha256sum] = "20a600d01fbb1f793cbb6f4ec4ebb2104f4c9e80d74d5f78350b63ecc6cccd08"
10
11PYPI_PACKAGE = "rfc3339_validator"
12
13inherit pypi setuptools3
14
15SRC_URI_append = " \
16 file://0001-setup.py-move-pytest-runner-to-test_requirements.patch \
17"
18
19RDEPENDS_${PN} += "\
20 ${PYTHON_PN}-core \
21 ${PYTHON_PN}-datetime \
22 ${PYTHON_PN}-six \
23"
24
25BBCLASSEXTEND = "native nativesdk"