diff options
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-arrow/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-arrow_1.3.0.bb | 30 |
2 files changed, 29 insertions, 4 deletions
diff --git a/meta-python/recipes-devtools/python/python3-arrow/run-ptest b/meta-python/recipes-devtools/python/python3-arrow/run-ptest new file mode 100644 index 0000000000..8d2017d39c --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-arrow/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest --automake | ||
diff --git a/meta-python/recipes-devtools/python/python3-arrow_1.3.0.bb b/meta-python/recipes-devtools/python/python3-arrow_1.3.0.bb index 90ba5de96f..c1b7c1a433 100644 --- a/meta-python/recipes-devtools/python/python3-arrow_1.3.0.bb +++ b/meta-python/recipes-devtools/python/python3-arrow_1.3.0.bb | |||
@@ -1,13 +1,35 @@ | |||
1 | SUMMARY = "Better dates and times for Python" | 1 | SUMMARY = "Better dates and times for Python" |
2 | HOMEPAGE = "https://github.com/crsmithdev/arrow" | 2 | HOMEPAGE = "https://github.com/arrow-py/arrow" |
3 | SECTION = "devel/python" | 3 | SECTION = "devel/python" |
4 | LICENSE = "Apache-2.0" | 4 | LICENSE = "Apache-2.0" |
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=14a2e29a9d542fb9052d75344d67619d" | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=14a2e29a9d542fb9052d75344d67619d" |
6 | 6 | ||
7 | SRC_URI[sha256sum] = "d4540617648cb5f895730f1ad8c82a65f2dad0166f57b75f3ca54759c4d67a85" | 7 | SRC_URI[sha256sum] = "d4540617648cb5f895730f1ad8c82a65f2dad0166f57b75f3ca54759c4d67a85" |
8 | 8 | ||
9 | inherit setuptools3 pypi | 9 | inherit pypi python_flit_core ptest |
10 | |||
11 | SRC_URI += " \ | ||
12 | file://run-ptest \ | ||
13 | " | ||
14 | |||
15 | RDEPENDS:${PN}-ptest += " \ | ||
16 | python3-dateutil-zoneinfo \ | ||
17 | python3-pytest \ | ||
18 | python3-pytest-mock \ | ||
19 | python3-pytz \ | ||
20 | python3-simplejson \ | ||
21 | python3-unittest-automake-output \ | ||
22 | " | ||
23 | |||
24 | do_install_ptest() { | ||
25 | install -d ${D}${PTEST_PATH}/tests | ||
26 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
27 | } | ||
10 | 28 | ||
11 | RDEPENDS:${PN} += " \ | 29 | RDEPENDS:${PN} += " \ |
12 | python3-dateutil \ | 30 | python3-compression \ |
13 | " | 31 | python3-dateutil \ |
32 | python3-dateutil-zoneinfo \ | ||
33 | python3-json \ | ||
34 | python3-types-python-dateutil \ | ||
35 | " | ||