summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python-whoosh.inc11
-rw-r--r--meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb7
2 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-whoosh.inc b/meta-python/recipes-devtools/python/python-whoosh.inc
index 0a2cf3bf44..f43d8c1b0c 100644
--- a/meta-python/recipes-devtools/python/python-whoosh.inc
+++ b/meta-python/recipes-devtools/python/python-whoosh.inc
@@ -12,3 +12,14 @@ SRC_URI[sha256sum] = "e0857375f63e9041e03fedd5b7541f97cf78917ac1b6b06c1fcc9b4537
12 12
13PYPI_PACKAGE = "Whoosh" 13PYPI_PACKAGE = "Whoosh"
14PYPI_PACKAGE_EXT = "zip" 14PYPI_PACKAGE_EXT = "zip"
15
16RDEPENDS_${PN} += " \
17 ${PYTHON_PN}-email \
18 ${PYTHON_PN}-multiprocessing \
19 ${PYTHON_PN}-netclient \
20 ${PYTHON_PN}-numbers \
21 ${PYTHON_PN}-pickle \
22 ${PYTHON_PN}-shell \
23 ${PYTHON_PN}-stringold \
24 ${PYTHON_PN}-subprocess \
25"
diff --git a/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb b/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb
index 5d8af303c7..4a4e679fbb 100644
--- a/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb
+++ b/meta-python/recipes-devtools/python/python3-whoosh_2.7.4.bb
@@ -1,2 +1,9 @@
1inherit pypi setuptools3 1inherit pypi setuptools3
2require python-whoosh.inc 2require python-whoosh.inc
3
4# Requires _pydecimal.py which is in misc
5RDEPENDS_${PN} += " \
6 ${PYTHON_PN}-enum \
7 ${PYTHON_PN}-misc \
8 ${PYTHON_PN}-selectors \
9"