summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-jdcal/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-jdcal_1.4.1.bb13
2 files changed, 2 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python3-jdcal/run-ptest b/meta-python/recipes-devtools/python/python3-jdcal/run-ptest
deleted file mode 100644
index 8d2017d39c..0000000000
--- a/meta-python/recipes-devtools/python/python3-jdcal/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-jdcal_1.4.1.bb b/meta-python/recipes-devtools/python/python3-jdcal_1.4.1.bb
index d20c9ad42f..d947a73cf0 100644
--- a/meta-python/recipes-devtools/python/python3-jdcal_1.4.1.bb
+++ b/meta-python/recipes-devtools/python/python3-jdcal_1.4.1.bb
@@ -7,21 +7,12 @@ HOMEPAGE = "https://github.com/phn/jdcal"
7LICENSE = "BSD-2-Clause" 7LICENSE = "BSD-2-Clause"
8LIC_FILES_CHKSUM = "file://PKG-INFO;md5=bd236e1f590973467a427bb354be0f46" 8LIC_FILES_CHKSUM = "file://PKG-INFO;md5=bd236e1f590973467a427bb354be0f46"
9 9
10inherit pypi setuptools3 ptest 10inherit pypi setuptools3 ptest-python-pytest
11 11
12SRC_URI[sha256sum] = "472872e096eb8df219c23f2689fc336668bdb43d194094b5cc1707e1640acfc8" 12SRC_URI[sha256sum] = "472872e096eb8df219c23f2689fc336668bdb43d194094b5cc1707e1640acfc8"
13 13
14RDEPENDS:${PN} += "python3-compression python3-io python3-pprint python3-shell" 14RDEPENDS:${PN} += "python3-compression python3-io python3-pprint python3-shell"
15 15
16SRC_URI += " \ 16do_install_ptest:append () {
17 file://run-ptest \
18"
19
20RDEPENDS:${PN}-ptest += " \
21 python3-pytest \
22 python3-unittest-automake-output \
23"
24
25do_install_ptest() {
26 cp -f ${S}/test_jdcal.py ${D}${PTEST_PATH}/ 17 cp -f ${S}/test_jdcal.py ${D}${PTEST_PATH}/
27} 18}