summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-dynamic-dispatch_1.0.2.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dynamic-dispatch_1.0.2.bb b/meta-python/recipes-devtools/python/python3-dynamic-dispatch_1.0.2.bb
new file mode 100644
index 0000000000..6485f9d575
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-dynamic-dispatch_1.0.2.bb
@@ -0,0 +1,18 @@
1SUMMARY = "dynamic dispatch decorator for classes and functions"
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=ea70b07c354e36056bd35e17c9c3face"
4
5inherit pypi setuptools3
6
7SRC_URI[md5sum] = "0e29d2afa806b9b87dadfbed6a0afd6d"
8SRC_URI[sha256sum] = "ec7025b2890e7a882ceef95ff82fd154265136af930cab42533070b557d2a15d"
9
10PYPI_PACKAGE = "dynamic_dispatch"
11
12DEPENDS += "python3-setuptools-scm-native"
13RDEPENDS_${PN} += "\
14 python3-typing \
15 python3-typeguard \
16"
17
18BBCLASSEXTEND = "native nativesdk"