diff options
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-cffi.inc | 17 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-cffi_1.14.0.bb | 19 |
2 files changed, 18 insertions, 18 deletions
diff --git a/meta-python/recipes-devtools/python/python-cffi.inc b/meta-python/recipes-devtools/python/python-cffi.inc deleted file mode 100644 index af10c5f36d..0000000000 --- a/meta-python/recipes-devtools/python/python-cffi.inc +++ /dev/null | |||
@@ -1,17 +0,0 @@ | |||
1 | SUMMARY = "Foreign Function Interface for Python calling C code" | ||
2 | HOMEPAGE = "http://cffi.readthedocs.org/" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=5677e2fdbf7cdda61d6dd2b57df547bf" | ||
5 | DEPENDS += "libffi ${PYTHON_PN}-pycparser" | ||
6 | |||
7 | SRC_URI[md5sum] = "74845f8d2b7b583dd9a3574f402edf39" | ||
8 | SRC_URI[sha256sum] = "2d384f4a127a15ba701207f7639d94106693b6cd64173d6c8988e2c25f3ac2b6" | ||
9 | |||
10 | RDEPENDS_${PN}_class-target = " \ | ||
11 | ${PYTHON_PN}-ctypes \ | ||
12 | ${PYTHON_PN}-io \ | ||
13 | ${PYTHON_PN}-pycparser \ | ||
14 | ${PYTHON_PN}-shell \ | ||
15 | " | ||
16 | |||
17 | BBCLASSEXTEND = "native nativesdk" | ||
diff --git a/meta-python/recipes-devtools/python/python3-cffi_1.14.0.bb b/meta-python/recipes-devtools/python/python3-cffi_1.14.0.bb index e888084347..53c8ee2650 100644 --- a/meta-python/recipes-devtools/python/python3-cffi_1.14.0.bb +++ b/meta-python/recipes-devtools/python/python3-cffi_1.14.0.bb | |||
@@ -1,2 +1,19 @@ | |||
1 | SUMMARY = "Foreign Function Interface for Python calling C code" | ||
2 | HOMEPAGE = "http://cffi.readthedocs.org/" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=5677e2fdbf7cdda61d6dd2b57df547bf" | ||
5 | DEPENDS += "libffi ${PYTHON_PN}-pycparser" | ||
6 | |||
7 | SRC_URI[md5sum] = "74845f8d2b7b583dd9a3574f402edf39" | ||
8 | SRC_URI[sha256sum] = "2d384f4a127a15ba701207f7639d94106693b6cd64173d6c8988e2c25f3ac2b6" | ||
9 | |||
1 | inherit pypi setuptools3 | 10 | inherit pypi setuptools3 |
2 | require python-cffi.inc | 11 | |
12 | RDEPENDS_${PN}_class-target = " \ | ||
13 | ${PYTHON_PN}-ctypes \ | ||
14 | ${PYTHON_PN}-io \ | ||
15 | ${PYTHON_PN}-pycparser \ | ||
16 | ${PYTHON_PN}-shell \ | ||
17 | " | ||
18 | |||
19 | BBCLASSEXTEND = "native nativesdk" | ||