diff options
Diffstat (limited to 'meta-python/recipes-devtools/python')
3 files changed, 11 insertions, 50 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pytest-mock/0001-test_pytest_mock-skip-args-introspection-tests.patch b/meta-python/recipes-devtools/python/python3-pytest-mock/0001-test_pytest_mock-skip-args-introspection-tests.patch deleted file mode 100644 index f024e79d93..0000000000 --- a/meta-python/recipes-devtools/python/python3-pytest-mock/0001-test_pytest_mock-skip-args-introspection-tests.patch +++ /dev/null | |||
@@ -1,38 +0,0 @@ | |||
1 | From e184fb950ad3b52c5c16438d39fe4d516c784e30 Mon Sep 17 00:00:00 2001 | ||
2 | From: Trevor Gamblin <tgamblin@baylibre.com> | ||
3 | Date: Thu, 12 Oct 2023 17:32:40 -0400 | ||
4 | Subject: [PATCH] test_pytest_mock: skip args introspection tests | ||
5 | |||
6 | Disable these two tests for now so that python3-pytest-mock can have | ||
7 | successful ptest runs. | ||
8 | |||
9 | Upstream-Status: Inappropriate [OE-Specific] | ||
10 | |||
11 | Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com> | ||
12 | --- | ||
13 | tests/test_pytest_mock.py | 2 ++ | ||
14 | 1 file changed, 2 insertions(+) | ||
15 | |||
16 | diff --git a/tests/test_pytest_mock.py b/tests/test_pytest_mock.py | ||
17 | index 3d53241..157b6c3 100644 | ||
18 | --- a/tests/test_pytest_mock.py | ||
19 | +++ b/tests/test_pytest_mock.py | ||
20 | @@ -581,6 +581,7 @@ def test_assert_called_wrapper(mocker: MockerFixture) -> None: | ||
21 | stub.assert_called() | ||
22 | |||
23 | |||
24 | +@pytest.mark.skip("Async not correctly detected, skip for now") | ||
25 | @pytest.mark.usefixtures("needs_assert_rewrite") | ||
26 | def test_assert_called_args_with_introspection(mocker: MockerFixture) -> None: | ||
27 | stub = mocker.stub() | ||
28 | @@ -597,6 +598,7 @@ def test_assert_called_args_with_introspection(mocker: MockerFixture) -> None: | ||
29 | stub.assert_called_once_with(*wrong_args) | ||
30 | |||
31 | |||
32 | +@pytest.mark.skip("Async not correctly detected, skip for now") | ||
33 | @pytest.mark.usefixtures("needs_assert_rewrite") | ||
34 | def test_assert_called_kwargs_with_introspection(mocker: MockerFixture) -> None: | ||
35 | stub = mocker.stub() | ||
36 | -- | ||
37 | 2.41.0 | ||
38 | |||
diff --git a/meta-python/recipes-devtools/python/python3-pytest-mock/run-ptest b/meta-python/recipes-devtools/python/python3-pytest-mock/run-ptest index 8d2017d39c..51ae892b01 100644 --- a/meta-python/recipes-devtools/python/python3-pytest-mock/run-ptest +++ b/meta-python/recipes-devtools/python/python3-pytest-mock/run-ptest | |||
@@ -1,3 +1,3 @@ | |||
1 | #!/bin/sh | 1 | #!/bin/sh |
2 | 2 | # see https://github.com/pytest-dev/pytest-mock/issues/102 for reasons to use plain asserts | |
3 | pytest --automake | 3 | pytest --automake --assert=plain |
diff --git a/meta-python/recipes-devtools/python/python3-pytest-mock_3.14.0.bb b/meta-python/recipes-devtools/python/python3-pytest-mock_3.14.0.bb index fe2479c836..b968cf1cd4 100644 --- a/meta-python/recipes-devtools/python/python3-pytest-mock_3.14.0.bb +++ b/meta-python/recipes-devtools/python/python3-pytest-mock_3.14.0.bb | |||
@@ -5,28 +5,27 @@ LIC_FILES_CHKSUM = " \ | |||
5 | file://LICENSE;md5=b2ddb1e69238461b7e4ef2a84d874109 \ | 5 | file://LICENSE;md5=b2ddb1e69238461b7e4ef2a84d874109 \ |
6 | " | 6 | " |
7 | 7 | ||
8 | SRC_URI = " \ | 8 | SRC_URI += " \ |
9 | git://github.com/pytest-dev/pytest-mock;branch=main;protocol=https \ | ||
10 | file://0001-test_pytest_mock-skip-args-introspection-tests.patch \ | ||
11 | file://run-ptest \ | 9 | file://run-ptest \ |
12 | " | 10 | " |
13 | SRCREV = "8733134b6194395e9cd3c745adcc9a9c09b0279e" | 11 | SRC_URI[sha256sum] = "2719255a1efeceadbc056d6bf3df3d1c5015530fb40cf347c0f9afac88410bd0" |
14 | 12 | ||
15 | inherit python_setuptools_build_meta ptest | 13 | inherit pypi python_setuptools_build_meta ptest |
14 | |||
15 | PYPI_PACKAGE = "pytest-mock" | ||
16 | 16 | ||
17 | DEPENDS += "python3-setuptools-scm-native" | 17 | DEPENDS += "python3-setuptools-scm-native" |
18 | 18 | ||
19 | RDEPENDS:${PN} += " \ | 19 | RDEPENDS:${PN}-ptest += " \ |
20 | python3-asyncio \ | 20 | python3-misc \ |
21 | python3-mock \ | 21 | python3-mock \ |
22 | python3-pytest \ | 22 | python3-pytest \ |
23 | python3-pytest-asyncio \ | 23 | python3-pytest-asyncio \ |
24 | python3-unittest \ | 24 | python3-threading \ |
25 | python3-tox \ | ||
25 | python3-unittest-automake-output \ | 26 | python3-unittest-automake-output \ |
26 | " | 27 | " |
27 | 28 | ||
28 | S = "${WORKDIR}/git" | ||
29 | |||
30 | do_install_ptest() { | 29 | do_install_ptest() { |
31 | install -d ${D}${PTEST_PATH}/tests | 30 | install -d ${D}${PTEST_PATH}/tests |
32 | cp -rf ${S}/tests ${D}${PTEST_PATH}/ | 31 | cp -rf ${S}/tests ${D}${PTEST_PATH}/ |