summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-typer_0.13.1.bb (renamed from meta-python/recipes-devtools/python/python3-typer_0.13.0.bb)13
1 files changed, 9 insertions, 4 deletions
diff --git a/meta-python/recipes-devtools/python/python3-typer_0.13.0.bb b/meta-python/recipes-devtools/python/python3-typer_0.13.1.bb
index 958c823545..465d747829 100644
--- a/meta-python/recipes-devtools/python/python3-typer_0.13.0.bb
+++ b/meta-python/recipes-devtools/python/python3-typer_0.13.1.bb
@@ -7,7 +7,7 @@ HOMEPAGE = "https://github.com/tiangolo/typer"
7LICENSE = "MIT" 7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=173d405eb704b1499218013178722617" 8LIC_FILES_CHKSUM = "file://LICENSE;md5=173d405eb704b1499218013178722617"
9 9
10SRC_URI[sha256sum] = "f1c7198347939361eec90139ffa0fd8b3df3a2259d5852a0f7400e476d95985c" 10SRC_URI[sha256sum] = "9d444cb96cc268ce6f8b94e13b4335084cef4c079998a9f4851a90229a3bd25c"
11 11
12inherit pypi python_setuptools_build_meta ptest 12inherit pypi python_setuptools_build_meta ptest
13 13
@@ -24,13 +24,19 @@ PYPI_PACKAGE = "typer"
24 24
25RDEPENDS:${PN} += "\ 25RDEPENDS:${PN} += "\
26 python3-click \ 26 python3-click \
27 python3-rich \
27 python3-shellingham \ 28 python3-shellingham \
29 python3-typing-extensions \
28" 30"
29 31# python3-misc for webbrowser module
30RDEPENDS:${PN}-ptest += "\ 32RDEPENDS:${PN}-ptest += "\
31 python3-coverage \ 33 python3-coverage \
34 python3-misc \
35 python3-mypy \
32 python3-pytest \ 36 python3-pytest \
33 python3-typing-extensions \ 37 python3-pytest-cov \
38 python3-pytest-xdist \
39 python3-toml \
34 python3-unittest-automake-output \ 40 python3-unittest-automake-output \
35" 41"
36 42
@@ -38,4 +44,3 @@ do_install_ptest() {
38 install -d ${D}${PTEST_PATH}/tests 44 install -d ${D}${PTEST_PATH}/tests
39 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ 45 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
40} 46}
41