diff options
Diffstat (limited to 'meta-python/recipes-devtools/python')
3 files changed, 21 insertions, 17 deletions
diff --git a/meta-python/recipes-devtools/python/python-django-south.inc b/meta-python/recipes-devtools/python/python-django-south.inc new file mode 100644 index 0000000000..ce904b6947 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-django-south.inc | |||
@@ -0,0 +1,17 @@ | |||
1 | SUMMARY = "Migrations for Django" | ||
2 | DESCRIPTION = "South is an intelligent database migrations library for the Django web framework. It is database-independent and DVCS-friendly, as well as a whole host of other features." | ||
3 | HOMEPAGE = "http://south.aeracode.org/" | ||
4 | LICENSE = "Apache-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=17;endline=18;md5=2155d8ae21e7c23101d5febac696b27e" | ||
6 | |||
7 | SRC_URI[md5sum] = "c76a9758b2011bc3b6c39f881bba2f66" | ||
8 | SRC_URI[sha256sum] = "d360bd31898f9df59f6faa786551065bba45b35e7ee3c39b381b4fbfef7392f4" | ||
9 | |||
10 | PYPI_PACKAGE = "South" | ||
11 | inherit pypi | ||
12 | |||
13 | BBCLASSEXTEND = "nativesdk" | ||
14 | |||
15 | RDEPENDS_${PN} += "\ | ||
16 | ${PYTHON_PN}-django \ | ||
17 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-django-south_1.0.2.bb b/meta-python/recipes-devtools/python/python-django-south_1.0.2.bb index 3a27758074..357b766a3d 100644 --- a/meta-python/recipes-devtools/python/python-django-south_1.0.2.bb +++ b/meta-python/recipes-devtools/python/python-django-south_1.0.2.bb | |||
@@ -1,17 +1,2 @@ | |||
1 | SUMMARY = "Migrations for Django" | 1 | require python-django-south.inc |
2 | DESCRIPTION = "South is an intelligent database migrations library for the Django web framework. It is database-independent and DVCS-friendly, as well as a whole host of other features." | 2 | inherit setuptools |
3 | HOMEPAGE = "http://south.aeracode.org/" | ||
4 | LICENSE = "Apache-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=17;endline=18;md5=2155d8ae21e7c23101d5febac696b27e" | ||
6 | |||
7 | SRC_URI[md5sum] = "c76a9758b2011bc3b6c39f881bba2f66" | ||
8 | SRC_URI[sha256sum] = "d360bd31898f9df59f6faa786551065bba45b35e7ee3c39b381b4fbfef7392f4" | ||
9 | |||
10 | PYPI_PACKAGE = "South" | ||
11 | inherit pypi setuptools | ||
12 | |||
13 | BBCLASSEXTEND = "nativesdk" | ||
14 | |||
15 | RDEPENDS_${PN} += "\ | ||
16 | ${PYTHON_PN}-django \ | ||
17 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-django-south_1.0.2.bb b/meta-python/recipes-devtools/python/python3-django-south_1.0.2.bb new file mode 100644 index 0000000000..10519111fa --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-django-south_1.0.2.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | require python-django-south.inc | ||
2 | inherit setuptools3 | ||