summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-cryptography/openssl3.patch62
-rw-r--r--meta-python/recipes-devtools/python/python3-cryptography_3.3.2.bb1
2 files changed, 63 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cryptography/openssl3.patch b/meta-python/recipes-devtools/python/python3-cryptography/openssl3.patch
new file mode 100644
index 0000000000..25baa42cc9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-cryptography/openssl3.patch
@@ -0,0 +1,62 @@
1Encourage our old python3-cryptography to at least start to work with OpenSSL 3.
2
3- Backport one patch to err.py to remove a symbol which has been removed in
4 OpenSSL 3, and isn't used in python3-cryptography.
5 (50ec692749b7e2e62685b443f5e629627b03987e)
6
7- Backport the detection of OpenSSL 3 and don't link to FIPS_mode/FIPS_mode_set
8 (parts of f08a7de651f9e6475c8c0a67d2a61ed8b669ddf6)
9
10This is *not* a complete backport of the 3.0 support, but is enough that packages
11such as imgtool can import python3-cryptography and operate until the upgrade is
12ready.
13
14Upstream-Status: Inappropriate
15Signed-off-by: Ross Burton <ross.burton@arm.com>
16
17diff --git a/src/_cffi_src/openssl/cryptography.py b/src/_cffi_src/openssl/cryptography.py
18index f24bee5a..920a86de 100644
19--- a/src/_cffi_src/openssl/cryptography.py
20+++ b/src/_cffi_src/openssl/cryptography.py
21@@ -35,6 +35,8 @@ INCLUDES = """
22
23 #define CRYPTOGRAPHY_OPENSSL_110F_OR_GREATER \
24 (OPENSSL_VERSION_NUMBER >= 0x1010006f && !CRYPTOGRAPHY_IS_LIBRESSL)
25+#define CRYPTOGRAPHY_OPENSSL_300_OR_GREATER \
26+ (OPENSSL_VERSION_NUMBER >= 0x30000000 && !CRYPTOGRAPHY_IS_LIBRESSL)
27
28 #define CRYPTOGRAPHY_OPENSSL_LESS_THAN_110J \
29 (OPENSSL_VERSION_NUMBER < 0x101000af || CRYPTOGRAPHY_IS_LIBRESSL)
30@@ -54,6 +56,7 @@ INCLUDES = """
31
32 TYPES = """
33 static const int CRYPTOGRAPHY_OPENSSL_110F_OR_GREATER;
34+static const int CRYPTOGRAPHY_OPENSSL_300_OR_GREATER;
35
36 static const int CRYPTOGRAPHY_OPENSSL_LESS_THAN_111;
37 static const int CRYPTOGRAPHY_OPENSSL_LESS_THAN_111B;
38diff --git a/src/_cffi_src/openssl/err.py b/src/_cffi_src/openssl/err.py
39index 0dd74146..42bab4d9 100644
40--- a/src/_cffi_src/openssl/err.py
41+++ b/src/_cffi_src/openssl/err.py
42@@ -40,7 +40,6 @@ void ERR_clear_error(void);
43 void ERR_put_error(int, int, int, const char *, int);
44
45 int ERR_GET_LIB(unsigned long);
46-int ERR_GET_FUNC(unsigned long);
47 int ERR_GET_REASON(unsigned long);
48
49 """
50diff --git a/src/_cffi_src/openssl/fips.py b/src/_cffi_src/openssl/fips.py
51index c92bca49..38bfa231 100644
52--- a/src/_cffi_src/openssl/fips.py
53+++ b/src/_cffi_src/openssl/fips.py
54@@ -18,7 +18,7 @@ int FIPS_mode(void);
55 """
56
57 CUSTOMIZATIONS = """
58-#if CRYPTOGRAPHY_IS_LIBRESSL
59+#if CRYPTOGRAPHY_IS_LIBRESSL || CRYPTOGRAPHY_OPENSSL_300_OR_GREATER
60 static const long Cryptography_HAS_FIPS = 0;
61 int (*FIPS_mode_set)(int) = NULL;
62 int (*FIPS_mode)(void) = NULL;
diff --git a/meta-python/recipes-devtools/python/python3-cryptography_3.3.2.bb b/meta-python/recipes-devtools/python/python3-cryptography_3.3.2.bb
index baec105a3e..8808b81625 100644
--- a/meta-python/recipes-devtools/python/python3-cryptography_3.3.2.bb
+++ b/meta-python/recipes-devtools/python/python3-cryptography_3.3.2.bb
@@ -11,6 +11,7 @@ SRC_URI[sha256sum] = "5a60d3780149e13b7a6ff7ad6526b38846354d11a15e21068e57073e29
11SRC_URI += " \ 11SRC_URI += " \
12 file://run-ptest \ 12 file://run-ptest \
13 file://h-test.patch \ 13 file://h-test.patch \
14 file://openssl3.patch \
14" 15"
15 16
16inherit pypi setuptools3 17inherit pypi setuptools3