diff options
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-rfc3339-validator/0001-setup.py-move-pytest-runner-to-test_requirements.patch | 32 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.2.bb (renamed from meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.1.bb) | 8 |
2 files changed, 2 insertions, 38 deletions
diff --git a/meta-python/recipes-devtools/python/python-rfc3339-validator/0001-setup.py-move-pytest-runner-to-test_requirements.patch b/meta-python/recipes-devtools/python/python-rfc3339-validator/0001-setup.py-move-pytest-runner-to-test_requirements.patch deleted file mode 100644 index ce8ca0bc8c..0000000000 --- a/meta-python/recipes-devtools/python/python-rfc3339-validator/0001-setup.py-move-pytest-runner-to-test_requirements.patch +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | From 2de281fdca88f223ace1eb6428a77b9903c69264 Mon Sep 17 00:00:00 2001 | ||
2 | From: Nicola Lunghi <nicola.lunghi@jci.com> | ||
3 | Date: Thu, 14 Nov 2019 11:58:28 +0000 | ||
4 | Subject: [PATCH] setup.py: move pytest-runner to test_requirements | ||
5 | |||
6 | This fixes an issue with yocto build. | ||
7 | pytest-runner is only needed when running tests. | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | --- | ||
11 | setup.py | 4 ++-- | ||
12 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
13 | |||
14 | diff --git a/setup.py b/setup.py | ||
15 | index 9a50767..e3b1c6e 100644 | ||
16 | --- a/setup.py | ||
17 | +++ b/setup.py | ||
18 | @@ -12,9 +12,9 @@ requirements = [ | ||
19 | 'six', | ||
20 | ] | ||
21 | |||
22 | -setup_requirements = ['pytest-runner', ] | ||
23 | +setup_requirements = [] | ||
24 | |||
25 | -test_requirements = ['pytest>=3', ] | ||
26 | +test_requirements = ['pytest>=3', 'pytest-runner'] | ||
27 | |||
28 | setup( | ||
29 | author="Nicolas Aimetti", | ||
30 | -- | ||
31 | 2.20.1 | ||
32 | |||
diff --git a/meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.1.bb b/meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.2.bb index 1f5d91d3b2..e226e11b75 100644 --- a/meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.1.bb +++ b/meta-python/recipes-devtools/python/python3-rfc3339-validator_0.1.2.bb | |||
@@ -5,17 +5,13 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=a21b13b5a996f08f7e0b088aa38ce9c6" | |||
5 | 5 | ||
6 | FILESEXTRAPATHS_prepend := "${THISDIR}/python-rfc3339-validator:" | 6 | FILESEXTRAPATHS_prepend := "${THISDIR}/python-rfc3339-validator:" |
7 | 7 | ||
8 | SRC_URI[md5sum] = "9d8899041d83f98180bddd8b62ee7e99" | 8 | SRC_URI[md5sum] = "2c233007189d5ef21046cb2afac51a96" |
9 | SRC_URI[sha256sum] = "20a600d01fbb1f793cbb6f4ec4ebb2104f4c9e80d74d5f78350b63ecc6cccd08" | 9 | SRC_URI[sha256sum] = "c9659c3183488a1875c4d327c9873d9e92c54cdcd69dfbfae7546ad8b27baf9a" |
10 | 10 | ||
11 | PYPI_PACKAGE = "rfc3339_validator" | 11 | PYPI_PACKAGE = "rfc3339_validator" |
12 | 12 | ||
13 | inherit pypi setuptools3 | 13 | inherit pypi setuptools3 |
14 | 14 | ||
15 | SRC_URI_append = " \ | ||
16 | file://0001-setup.py-move-pytest-runner-to-test_requirements.patch \ | ||
17 | " | ||
18 | |||
19 | RDEPENDS_${PN} += "\ | 15 | RDEPENDS_${PN} += "\ |
20 | ${PYTHON_PN}-core \ | 16 | ${PYTHON_PN}-core \ |
21 | ${PYTHON_PN}-datetime \ | 17 | ${PYTHON_PN}-datetime \ |