diff options
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch | 12 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pyzmq_22.0.2.bb (renamed from meta-python/recipes-devtools/python/python3-pyzmq_21.0.2.bb) | 2 |
2 files changed, 6 insertions, 8 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch b/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch index d4e144a610..61aeaca5fa 100644 --- a/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch +++ b/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From b394003d31a7187767b7d6cc7b871968d2674be9 Mon Sep 17 00:00:00 2001 | 1 | From efae4e08d13e0958d929ea524e21c0a210b31982 Mon Sep 17 00:00:00 2001 |
2 | From: Leon Anavi <leon.anavi@konsulko.com> | 2 | From: Leon Anavi <leon.anavi@konsulko.com> |
3 | Date: Fri, 22 Jan 2021 11:41:12 +0200 | 3 | Date: Fri, 22 Jan 2021 11:41:12 +0200 |
4 | Subject: [PATCH] setup.py: Adjust _add_rpath | 4 | Subject: [PATCH] setup.py: Adjust _add_rpath |
@@ -8,15 +8,16 @@ Fix error: unrecognized command-line option '-R' | |||
8 | Upstream-Status: Inappropriate [oe specific] | 8 | Upstream-Status: Inappropriate [oe specific] |
9 | 9 | ||
10 | Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> | 10 | Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> |
11 | |||
11 | --- | 12 | --- |
12 | setup.py | 3 --- | 13 | setup.py | 3 --- |
13 | 1 file changed, 3 deletions(-) | 14 | 1 file changed, 3 deletions(-) |
14 | 15 | ||
15 | diff --git a/setup.py b/setup.py | 16 | diff --git a/setup.py b/setup.py |
16 | index 22f582d..2d28655 100755 | 17 | index b634d94..7f6a2f1 100755 |
17 | --- a/setup.py | 18 | --- a/setup.py |
18 | +++ b/setup.py | 19 | +++ b/setup.py |
19 | @@ -231,9 +231,6 @@ def _add_rpath(settings, path): | 20 | @@ -235,9 +235,6 @@ def _add_rpath(settings, path): |
20 | """ | 21 | """ |
21 | if sys.platform == 'darwin': | 22 | if sys.platform == 'darwin': |
22 | settings['extra_link_args'].extend(['-Wl,-rpath', '-Wl,%s' % path]) | 23 | settings['extra_link_args'].extend(['-Wl,-rpath', '-Wl,%s' % path]) |
@@ -24,8 +25,5 @@ index 22f582d..2d28655 100755 | |||
24 | - settings['runtime_library_dirs'].append(path) | 25 | - settings['runtime_library_dirs'].append(path) |
25 | - | 26 | - |
26 | 27 | ||
27 | def settings_from_prefix(prefix=None, bundle_libzmq_dylib=False): | 28 | def settings_from_prefix(prefix=None): |
28 | """load appropriate library/include settings from ZMQ prefix""" | 29 | """load appropriate library/include settings from ZMQ prefix""" |
29 | -- | ||
30 | 2.17.1 | ||
31 | |||
diff --git a/meta-python/recipes-devtools/python/python3-pyzmq_21.0.2.bb b/meta-python/recipes-devtools/python/python3-pyzmq_22.0.2.bb index 8bde98247d..555f27cb49 100644 --- a/meta-python/recipes-devtools/python/python3-pyzmq_21.0.2.bb +++ b/meta-python/recipes-devtools/python/python3-pyzmq_22.0.2.bb | |||
@@ -8,7 +8,7 @@ DEPENDS = "zeromq" | |||
8 | FILESEXTRAPATHS_prepend := "${THISDIR}/python-pyzmq:" | 8 | FILESEXTRAPATHS_prepend := "${THISDIR}/python-pyzmq:" |
9 | 9 | ||
10 | SRC_URI += "file://club-rpath-out.patch" | 10 | SRC_URI += "file://club-rpath-out.patch" |
11 | SRC_URI[sha256sum] = "098c13c6198913c2a0690235fa74d2e49161755f66b663beaec89651554cc79c" | 11 | SRC_URI[sha256sum] = "d7b82a959e5e22d492f4f5a1e650e909a6c8c76ede178f538313ddb9d1e92963" |
12 | 12 | ||
13 | inherit pypi pkgconfig setuptools3 | 13 | inherit pypi pkgconfig setuptools3 |
14 | 14 | ||