summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-ipy/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-ipy_1.01.bb32
2 files changed, 0 insertions, 35 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ipy/run-ptest b/meta-python/recipes-devtools/python/python3-ipy/run-ptest
deleted file mode 100644
index b63c4de0d9..0000000000
--- a/meta-python/recipes-devtools/python/python3-ipy/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@
1#!/bin/sh
2
3pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta-python/recipes-devtools/python/python3-ipy_1.01.bb b/meta-python/recipes-devtools/python/python3-ipy_1.01.bb
deleted file mode 100644
index 8b39679e45..0000000000
--- a/meta-python/recipes-devtools/python/python3-ipy_1.01.bb
+++ /dev/null
@@ -1,32 +0,0 @@
1SUMMARY = "IPy - class and tools for handling of IPv4 and IPv6 addresses and networks"
2DESCRIPTION = "IPy is a Python module for handling IPv4 and IPv6 Addresses and Networks \
3in a fashion similar to perl's Net::IP and friends. The IP class allows \
4a comfortable parsing and handling for most notations in use for IPv4 \
5and IPv6 Addresses and Networks."
6SECTION = "devel/python"
7HOMEPAGE = "https://github.com/autocracy/python-ipy"
8
9LICENSE = "BSD-3-Clause"
10LIC_FILES_CHKSUM = "file://COPYING;md5=848d24919845901b4f48bae5f13252e6"
11
12SRC_URI[md5sum] = "d6cf83e7f418ebbd23324ba1c658b907"
13SRC_URI[sha256sum] = "edeca741dea2d54aca568fa23740288c3fe86c0f3ea700344571e9ef14a7cc1a"
14
15inherit pypi setuptools3 ptest
16
17SRC_URI += " \
18 file://run-ptest \
19"
20
21RDEPENDS:${PN}-ptest += " \
22 ${PYTHON_PN}-pytest \
23"
24
25do_install_ptest() {
26 install -d ${D}${PTEST_PATH}/test/
27 cp -rf ${S}/test/* ${D}${PTEST_PATH}/test
28}
29
30PYPI_PACKAGE = "IPy"
31
32BBCLASSEXTEND = "native"