diff options
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-multidict/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-multidict_4.7.4.bb | 15 |
2 files changed, 17 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-multidict/run-ptest b/meta-python/recipes-devtools/python/python3-multidict/run-ptest new file mode 100644 index 0000000000..5cec711696 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-multidict/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest | ||
diff --git a/meta-python/recipes-devtools/python/python3-multidict_4.7.4.bb b/meta-python/recipes-devtools/python/python3-multidict_4.7.4.bb index f16a7be7a6..0636972ec9 100644 --- a/meta-python/recipes-devtools/python/python3-multidict_4.7.4.bb +++ b/meta-python/recipes-devtools/python/python3-multidict_4.7.4.bb | |||
@@ -3,7 +3,20 @@ HOMEPAGE = "https://github.com/aio-libs/multidict/" | |||
3 | LICENSE = "Apache-2.0" | 3 | LICENSE = "Apache-2.0" |
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e74c98abe0de8f798ca609137f9cef4a" | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e74c98abe0de8f798ca609137f9cef4a" |
5 | 5 | ||
6 | inherit pypi setuptools3 | 6 | inherit pypi setuptools3 ptest |
7 | 7 | ||
8 | SRC_URI[md5sum] = "22b46f759cf2cc3ca1d2c9f82cc9bb79" | 8 | SRC_URI[md5sum] = "22b46f759cf2cc3ca1d2c9f82cc9bb79" |
9 | SRC_URI[sha256sum] = "d7d428488c67b09b26928950a395e41cc72bb9c3d5abfe9f0521940ee4f796d4" | 9 | SRC_URI[sha256sum] = "d7d428488c67b09b26928950a395e41cc72bb9c3d5abfe9f0521940ee4f796d4" |
10 | |||
11 | SRC_URI += " \ | ||
12 | file://run-ptest \ | ||
13 | " | ||
14 | |||
15 | RDEPENDS_${PN}-ptest += " \ | ||
16 | ${PYTHON_PN}-pytest \ | ||
17 | " | ||
18 | |||
19 | do_install_ptest() { | ||
20 | install -d ${D}${PTEST_PATH}/tests | ||
21 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
22 | } | ||