diff options
Diffstat (limited to 'meta-python/recipes-devtools/python')
4 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-flask-xstatic.inc b/meta-python/recipes-devtools/python/python-flask-xstatic.inc new file mode 100644 index 0000000000..a1fe14ed46 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-flask-xstatic.inc | |||
@@ -0,0 +1,16 @@ | |||
1 | DESCRIPTION = "XStatic support for flask" | ||
2 | LICENSE = "BSD" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=659968f6ebd4b70b6c3190d20b4a924c" | ||
4 | |||
5 | SRC_URI[md5sum] = "2f56023e1444c8bd1fec41afe93de743" | ||
6 | SRC_URI[sha256sum] = "226ea8e97065a9488b59bfe5c94af4c6e2ea70a25052e301fb231a1381490133" | ||
7 | |||
8 | FILESEXTRAPATHS_prepend := "${THISDIR}/python-flask-xstatic:" | ||
9 | SRC_URI += "file://remove-pip-requires.patch" | ||
10 | |||
11 | PYPI_PACKAGE = "Flask-XStatic" | ||
12 | |||
13 | RDEPENDS_${PN} += "\ | ||
14 | ${PYTHON_PN}-flask \ | ||
15 | ${PYTHON_PN}-xstatic \ | ||
16 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-flask-xstatic/remove-pip-requires.patch b/meta-python/recipes-devtools/python/python-flask-xstatic/remove-pip-requires.patch new file mode 100644 index 0000000000..a2d620ad06 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-flask-xstatic/remove-pip-requires.patch | |||
@@ -0,0 +1,7 @@ | |||
1 | --- Flask-XStatic-0.0.1/setup.py.orig 2015-01-30 08:01:56.000000000 -0800 | ||
2 | +++ Flask-XStatic-0.0.1/setup.py 2017-04-17 21:40:32.570181626 -0700 | ||
3 | @@ -1,4 +1,3 @@ | ||
4 | -from pip.req import parse_requirements | ||
5 | import setuptools | ||
6 | |||
7 | with open('README.rst') as f: | ||
diff --git a/meta-python/recipes-devtools/python/python-flask-xstatic_0.0.1.bb b/meta-python/recipes-devtools/python/python-flask-xstatic_0.0.1.bb new file mode 100644 index 0000000000..dff14a8c05 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-flask-xstatic_0.0.1.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit pypi setuptools | ||
2 | require python-flask-xstatic.inc | ||
diff --git a/meta-python/recipes-devtools/python/python3-flask-xstatic_0.0.1.bb b/meta-python/recipes-devtools/python/python3-flask-xstatic_0.0.1.bb new file mode 100644 index 0000000000..5412befdb5 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-flask-xstatic_0.0.1.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit pypi setuptools3 | ||
2 | require python-flask-xstatic.inc | ||