diff options
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-haversine/0001-setup.py-Correct-the-license-assignment.patch | 32 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-haversine_2.3.1.bb (renamed from meta-python/recipes-devtools/python/python3-haversine_2.3.0.bb) | 5 |
2 files changed, 1 insertions, 36 deletions
diff --git a/meta-python/recipes-devtools/python/python3-haversine/0001-setup.py-Correct-the-license-assignment.patch b/meta-python/recipes-devtools/python/python3-haversine/0001-setup.py-Correct-the-license-assignment.patch deleted file mode 100644 index bb5955a44e..0000000000 --- a/meta-python/recipes-devtools/python/python3-haversine/0001-setup.py-Correct-the-license-assignment.patch +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | From 56b421a18ef8acb41ab9e4bde7e1f5452ec67da9 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 17 May 2021 22:17:07 -0700 | ||
4 | Subject: [PATCH] setup.py: Correct the license assignment | ||
5 | |||
6 | latest python/2.9 + setuptools bail out otherwise | ||
7 | |||
8 | lines = header.split('\n') | ||
9 | | AttributeError: 'list' object has no attribute 'split' | ||
10 | |||
11 | Upstream-Status: Submitted [https://github.com/mapado/haversine/pull/38] | ||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | setup.py | 2 +- | ||
15 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
16 | |||
17 | diff --git a/setup.py b/setup.py | ||
18 | index 549436d..9e7fb00 100755 | ||
19 | --- a/setup.py | ||
20 | +++ b/setup.py | ||
21 | @@ -15,7 +15,7 @@ setup( | ||
22 | maintainer_email='julien.deniau@mapado.com', | ||
23 | url='https://github.com/mapado/haversine', | ||
24 | packages=['haversine'], | ||
25 | - license=['MIT'], | ||
26 | + license='MIT', | ||
27 | classifiers=[ | ||
28 | 'Development Status :: 4 - Beta', | ||
29 | 'Intended Audience :: Developers', | ||
30 | -- | ||
31 | 2.31.1 | ||
32 | |||
diff --git a/meta-python/recipes-devtools/python/python3-haversine_2.3.0.bb b/meta-python/recipes-devtools/python/python3-haversine_2.3.1.bb index 624d30ca01..c3251624f5 100644 --- a/meta-python/recipes-devtools/python/python3-haversine_2.3.0.bb +++ b/meta-python/recipes-devtools/python/python3-haversine_2.3.1.bb | |||
@@ -2,10 +2,7 @@ SUMMARY = "Calculate the distance between 2 points on Earth" | |||
2 | LICENSE = "MIT" | 2 | LICENSE = "MIT" |
3 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302" | 3 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302" |
4 | 4 | ||
5 | SRC_URI += "file://0001-setup.py-Correct-the-license-assignment.patch" | 5 | SRC_URI[sha256sum] = "75a7f859b3fb6df746564ca66ad1fd5b4052cdbab3d74ff16e8f1a7c3d4a26a5" |
6 | |||
7 | SRC_URI[md5sum] = "ff2d43a74195ec00c42ccd5da2a3f3de" | ||
8 | SRC_URI[sha256sum] = "72c76855ac25e6ad054c7ed380e95c1a96803185f005dd11f40ccaa9620b551f" | ||
9 | 6 | ||
10 | inherit pypi setuptools3 | 7 | inherit pypi setuptools3 |
11 | 8 | ||