summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python')
-rw-r--r--meta-python/recipes-devtools/python/python3-rlp/0001-setup-don-t-use-setuptools-markdown.patch37
-rw-r--r--meta-python/recipes-devtools/python/python3-rlp_4.0.0.bb (renamed from meta-python/recipes-devtools/python/python3-rlp_3.0.0.bb)8
2 files changed, 5 insertions, 40 deletions
diff --git a/meta-python/recipes-devtools/python/python3-rlp/0001-setup-don-t-use-setuptools-markdown.patch b/meta-python/recipes-devtools/python/python3-rlp/0001-setup-don-t-use-setuptools-markdown.patch
deleted file mode 100644
index 0ab012a982..0000000000
--- a/meta-python/recipes-devtools/python/python3-rlp/0001-setup-don-t-use-setuptools-markdown.patch
+++ /dev/null
@@ -1,37 +0,0 @@
1From 5a2db801c6520be296cee9cba0e0e4ffac68430c Mon Sep 17 00:00:00 2001
2From: Bartosz Golaszewski <brgl@bgdev.pl>
3Date: Wed, 11 May 2022 15:11:19 +0200
4Subject: [PATCH] setup: don't use setuptools-markdown
5
6This project is deprecated and irrelevant for the functionality of
7pyrlp. We don't support it in meta-python so just drop it from the
8dependencies.
9
10Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
11---
12Upstream-Status: Pending
13
14 setup.py | 2 --
15 1 file changed, 2 deletions(-)
16
17diff --git a/setup.py b/setup.py
18index 1055fb1..55fca24 100755
19--- a/setup.py
20+++ b/setup.py
21@@ -46,13 +46,11 @@ setup(
22 # *IMPORTANT*: Don't manually change the version here. See README for more.
23 version='3.0.0',
24 description="A package for Recursive Length Prefix encoding and decoding",
25- long_description_markdown_filename='README.md',
26 author="jnnk",
27 author_email='jnnknnj@gmail.com',
28 url='https://github.com/ethereum/pyrlp',
29 packages=find_packages(exclude=["tests", "tests.*"]),
30 include_package_data=True,
31- setup_requires=['setuptools-markdown'],
32 install_requires=[
33 "eth-utils>=2.0.0,<3",
34 ],
35--
362.34.1
37
diff --git a/meta-python/recipes-devtools/python/python3-rlp_3.0.0.bb b/meta-python/recipes-devtools/python/python3-rlp_4.0.0.bb
index e747ae33ba..49efd09a4b 100644
--- a/meta-python/recipes-devtools/python/python3-rlp_3.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-rlp_4.0.0.bb
@@ -4,11 +4,13 @@ SECTION = "devel/python"
4LICENSE = "MIT" 4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=00854fa80a84236706b11f47f23e61e7" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=00854fa80a84236706b11f47f23e61e7"
6 6
7SRC_URI[sha256sum] = "63b0465d2948cd9f01de449d7adfb92d207c1aef3982f20310f8009be4a507e8" 7SRC_URI[sha256sum] = "61a5541f86e4684ab145cb849a5929d2ced8222930a570b3941cf4af16b72a78"
8SRC_URI += "file://0001-setup-don-t-use-setuptools-markdown.patch"
9 8
10inherit pypi setuptools3 9inherit pypi setuptools3
11 10
12DEPENDS += "python3-pip-native" 11DEPENDS += "python3-pip-native"
13 12
14RDEPENDS:${PN} += "python3-eth-utils" 13RDEPENDS:${PN} += " \
14 ${PYTHON_PN}-eth-utils \
15 ${PYTHON_PN}-typing-extensions \
16"