summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch26
-rw-r--r--meta-python/recipes-devtools/python/python-pyzmq_14.5.0.bb27
2 files changed, 53 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch b/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch
new file mode 100644
index 0000000000..2dc3b73f9e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch
@@ -0,0 +1,26 @@
1diff --git a/setup.py b/setup.py
2index 62df445..1fdbdeb 100755
3--- a/setup.py
4+++ b/setup.py
5@@ -213,12 +213,6 @@ def settings_from_prefix(prefix=None, bundle_libzmq_dylib=False):
6 pass
7 # unused rpath args for OS X:
8 # settings['extra_link_args'] = ['-Wl,-rpath','-Wl,$ORIGIN/..']
9- else:
10- settings['runtime_library_dirs'] += ['$ORIGIN/..']
11- elif sys.platform != 'darwin':
12- settings['runtime_library_dirs'] += [
13- os.path.abspath(x) for x in settings['library_dirs']
14- ]
15
16 return settings
17
18@@ -592,8 +586,6 @@ class Configure(build_ext):
19 pass
20 # unused rpath args for OS X:
21 # settings['extra_link_args'] = ['-Wl,-rpath','-Wl,$ORIGIN/../zmq']
22- else:
23- settings['runtime_library_dirs'] = [ os.path.abspath(pjoin('.', 'zmq')) ]
24
25 line()
26 info("Configure: Autodetecting ZMQ settings...")
diff --git a/meta-python/recipes-devtools/python/python-pyzmq_14.5.0.bb b/meta-python/recipes-devtools/python/python-pyzmq_14.5.0.bb
new file mode 100644
index 0000000000..626e29d960
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pyzmq_14.5.0.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Pyzmq provides Zero message queue access for the Python language"
2HOMEPAGE = "http://zeromq.org/bindings:python"
3SECTION = "devel/python"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://COPYING.BSD;md5=11c65680f637c3df7f58bbc8d133e96e"
6DEPENDS = "zeromq"
7
8SRC_URI = "https://pypi.python.org/packages/source/p/pyzmq/pyzmq-${PV}.tar.gz \
9 file://club-rpath-out.patch \
10"
11SRC_URI[md5sum] = "8d3351a8ca2ca2a272a3f96bcb963e41"
12SRC_URI[sha256sum] = "5d6e045634456cf5496f50871fd3e3a5ede2b90433284dbfe985bb67c97f77bd"
13
14S = "${WORKDIR}/pyzmq-${PV}"
15
16inherit setuptools pkgconfig
17
18FILES_${PN}-dbg =+ "${PYTHON_SITEPACKAGES_DIR}/zmq/backend/cython/.debug"
19
20do_compile_prepend() {
21 echo [global] > ${S}/setup.cfg
22 echo zmq_prefix = ${STAGING_DIR_HOST} >> ${S}/setup.cfg
23 echo have_sys_un_h = True >> ${S}/setup.cfg
24 echo skip_check_zmq = True >> ${S}/setup.cfg
25 echo libzmq_extension = False >> ${S}/setup.cfg
26 echo no_libzmq_extension = True >> ${S}/setup.cfg
27}