summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch')
-rw-r--r--meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch31
1 files changed, 0 insertions, 31 deletions
diff --git a/meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch b/meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch
deleted file mode 100644
index 2eb6be5a18..0000000000
--- a/meta-python/recipes-extended/python-meh/python3-meh/0001-setup.py-switch-from-distutils-to-setuptools.patch
+++ /dev/null
@@ -1,31 +0,0 @@
1From 034ac41561409ffc7836683331b6b94a641436e4 Mon Sep 17 00:00:00 2001
2From: Tim Orling <tim.orling@konsulko.com>
3Date: Mon, 28 Feb 2022 09:41:02 -0800
4Subject: [PATCH] setup.py: switch from distutils to setuptools
5
6In Python 3.10 'distutils' is deprecated with removal slated for Python
73.12. Switch from 'distutils.core' to 'setuptools'.
8
9This also allows for a 'wheel' binary archive format to be built with
10'setup.py bdist_wheel'.
11
12Upstream-Status: Backport [cf9eafdd165347f86bb4a2534c41fd805db52322]
13
14Signed-off-by: Tim Orling <tim.orling@konsulko.com>
15
16---
17 setup.py | 2 +-
18 1 file changed, 1 insertion(+), 1 deletion(-)
19
20diff --git a/setup.py b/setup.py
21index 9c12180..3ba5195 100644
22--- a/setup.py
23+++ b/setup.py
24@@ -1,6 +1,6 @@
25 #!/usr/bin/python3
26
27-from distutils.core import setup
28+from setuptools import setup
29
30 setup(name='python-meh', version='0.50.1',
31 description='Python module for handling exceptions',