diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-poetry-core_1.0.8.bb | 56 |
1 files changed, 56 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-poetry-core_1.0.8.bb b/meta-python/recipes-devtools/python/python3-poetry-core_1.0.8.bb new file mode 100644 index 0000000000..0941af9ff9 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-poetry-core_1.0.8.bb | |||
@@ -0,0 +1,56 @@ | |||
1 | SUMMARY = "Poetry PEP 517 Build Backend" | ||
2 | DESCRIPTION = "Poetry PEP 517 Build Backend" | ||
3 | HOMEPAGE = "https://github.com/python-poetry/poetry-core" | ||
4 | BUGTRACKER = "https://github.com/python-poetry/poetry-core" | ||
5 | CHANGELOG = "https://github.com/python-poetry/poetry-core/blob/master/CHANGELOG.md" | ||
6 | |||
7 | LICENSE = "Apache-2.0 & BSD-2-Clause & MIT" | ||
8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=104d5c3c653aeededf4076773aa4c236 \ | ||
9 | file://poetry/core/_vendor/attrs.LICENSE;md5=75bb9823a2778b5a2bd9b793fac93ea2 \ | ||
10 | file://poetry/core/_vendor/jsonschema/COPYING;md5=6554d3a51d7cb0b611891317f3c69057 \ | ||
11 | file://poetry/core/_vendor/jsonschema/LICENSE;md5=2ecb81765361195731a6f72a89e449fd \ | ||
12 | file://poetry/core/_vendor/lark-parser.LICENSE;md5=b37b83a9cf129d92ee65aaa71c01ce72 \ | ||
13 | file://poetry/core/_vendor/packaging/LICENSE;md5=7a6e56c9d54ecd731ab31c52de7942f0 \ | ||
14 | file://poetry/core/_vendor/packaging/LICENSE.APACHE;md5=29256199be2a609aac596980ffc11996 \ | ||
15 | file://poetry/core/_vendor/packaging/LICENSE.BSD;md5=f405810d173a1618433827928768bcd2 \ | ||
16 | file://poetry/core/_vendor/pyparsing.LICENSE;md5=fb46329938e6bc829b256e37d5c1e31a \ | ||
17 | file://poetry/core/_vendor/pyrsistent/LICENSE.mit;md5=1211a1ac6eac40020d0f99c39b4e4270 \ | ||
18 | file://poetry/core/_vendor/six.LICENSE;md5=6a574656da93d9ef05431b45907e35b6 \ | ||
19 | file://poetry/core/_vendor/tomlkit/LICENSE;md5=be329e5ef9c9fe86738c9afe6ef3c11c \ | ||
20 | " | ||
21 | |||
22 | SRC_URI[sha256sum] = "951fc7c1f8d710a94cb49019ee3742125039fc659675912ea614ac2aa405b118" | ||
23 | |||
24 | inherit pip_install_wheel python3native python3-dir pypi setuptools3-base | ||
25 | |||
26 | RDEPENDS:${PN}:append:class-target = "\ | ||
27 | python3-compression \ | ||
28 | python3-core \ | ||
29 | python3-crypt \ | ||
30 | python3-io \ | ||
31 | python3-json \ | ||
32 | python3-logging \ | ||
33 | python3-netclient \ | ||
34 | python3-pathlib2 \ | ||
35 | python3-pprint \ | ||
36 | python3-shell \ | ||
37 | " | ||
38 | |||
39 | RDEPENDS:${PN} += "\ | ||
40 | python3-pip \ | ||
41 | python3-six \ | ||
42 | " | ||
43 | |||
44 | do_configure () { | ||
45 | mkdir -p ${B}/dist | ||
46 | cat > ${B}/build-it.py << EOF | ||
47 | from poetry.core.masonry import api | ||
48 | api.build_wheel('${B}/dist') | ||
49 | EOF | ||
50 | } | ||
51 | |||
52 | do_compile () { | ||
53 | ${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} ${B}/build-it.py | ||
54 | } | ||
55 | |||
56 | BBCLASSEXTEND = "native nativesdk" | ||