diff options
Diffstat (limited to 'meta-python')
-rwxr-xr-x | meta-python/recipes-devtools/python/python-pytz.inc | 15 | ||||
-rwxr-xr-x[-rw-r--r--] | meta-python/recipes-devtools/python/python-pytz_2016.7.bb | 17 | ||||
-rwxr-xr-x | meta-python/recipes-devtools/python/python3-pytz_2016.7.bb | 2 |
3 files changed, 19 insertions, 15 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytz.inc b/meta-python/recipes-devtools/python/python-pytz.inc new file mode 100755 index 0000000000..19be2c7571 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-pytz.inc | |||
@@ -0,0 +1,15 @@ | |||
1 | SUMMARY = "World timezone definitions, modern and historical" | ||
2 | HOMEPAGE = "http://pythonhosted.org/pytz" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=22b38951eb857cf285a4560a914b7cd6" | ||
5 | |||
6 | inherit pypi | ||
7 | |||
8 | SRC_URI[md5sum] = "8660ba7c3c0abd23e6e4efa493b02966" | ||
9 | SRC_URI[sha256sum] = "8787de03f35f31699bcaf127e56ad14c00647965ed24d72dbaca87c6e4f843a3" | ||
10 | |||
11 | RDEPENDS_${PN} += "\ | ||
12 | ${PYTHON_PN}-datetime \ | ||
13 | ${PYTHON_PN}-io \ | ||
14 | ${PYTHON_PN}-threading \ | ||
15 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-pytz_2016.7.bb b/meta-python/recipes-devtools/python/python-pytz_2016.7.bb index 508fd3b54f..f2ffc596f8 100644..100755 --- a/meta-python/recipes-devtools/python/python-pytz_2016.7.bb +++ b/meta-python/recipes-devtools/python/python-pytz_2016.7.bb | |||
@@ -1,15 +1,2 @@ | |||
1 | SUMMARY = "World timezone definitions, modern and historical" | 1 | inherit setuptools |
2 | HOMEPAGE = " http://pythonhosted.org/pytz" | 2 | require python-pytz.inc |
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=22b38951eb857cf285a4560a914b7cd6" | ||
5 | |||
6 | SRC_URI[md5sum] = "8660ba7c3c0abd23e6e4efa493b02966" | ||
7 | SRC_URI[sha256sum] = "8787de03f35f31699bcaf127e56ad14c00647965ed24d72dbaca87c6e4f843a3" | ||
8 | |||
9 | inherit pypi setuptools | ||
10 | |||
11 | RDEPENDS_${PN} += "\ | ||
12 | ${PYTHON_PN}-datetime \ | ||
13 | ${PYTHON_PN}-io \ | ||
14 | ${PYTHON_PN}-threading \ | ||
15 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-pytz_2016.7.bb b/meta-python/recipes-devtools/python/python3-pytz_2016.7.bb new file mode 100755 index 0000000000..19a89dc55d --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pytz_2016.7.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-pytz.inc | ||