diff options
Diffstat (limited to 'meta-python')
2 files changed, 33 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-scikit-build-core/0001-builder.py-Check-PYTHON_INCLUDE_DIR.patch b/meta-python/recipes-devtools/python/python3-scikit-build-core/0001-builder.py-Check-PYTHON_INCLUDE_DIR.patch new file mode 100644 index 0000000000..13cb7b1e7f --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-scikit-build-core/0001-builder.py-Check-PYTHON_INCLUDE_DIR.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From 5bc2d175c6a31a3de04444e5e22af310799ab10d Mon Sep 17 00:00:00 2001 | ||
2 | From: Leon Anavi <leon.anavi@konsulko.com> | ||
3 | Date: Mon, 27 Jan 2025 19:17:48 +0200 | ||
4 | Subject: [PATCH] builder.py: Check PYTHON_INCLUDE_DIR | ||
5 | |||
6 | Use PYTHON_INCLUDE_DIR to find Python Interpreter and | ||
7 | Development.Module. | ||
8 | |||
9 | Upstream-Status: Inappropriate [oe specific] | ||
10 | |||
11 | Suggested-by: Stephan Kulow <stephan.kulow@siemens.com> | ||
12 | Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> | ||
13 | --- | ||
14 | src/scikit_build_core/builder/builder.py | 2 +- | ||
15 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
16 | |||
17 | diff --git a/src/scikit_build_core/builder/builder.py b/src/scikit_build_core/builder/builder.py | ||
18 | index b19173f..f4fb2af 100644 | ||
19 | --- a/src/scikit_build_core/builder/builder.py | ||
20 | +++ b/src/scikit_build_core/builder/builder.py | ||
21 | @@ -203,7 +203,7 @@ class Builder: | ||
22 | python_sabi_library = ( | ||
23 | get_python_library(self.config.env, abi3=True) if limited_api else None | ||
24 | ) | ||
25 | - python_include_dir = get_python_include_dir() | ||
26 | + python_include_dir = os.getenv("PYTHON_INCLUDE_DIR") or get_python_include_dir() | ||
27 | numpy_include_dir = get_numpy_include_dir() | ||
28 | |||
29 | # Classic Find Python | ||
30 | -- | ||
31 | 2.39.5 | ||
32 | |||
diff --git a/meta-python/recipes-devtools/python/python3-scikit-build-core_0.10.7.bb b/meta-python/recipes-devtools/python/python3-scikit-build-core_0.10.7.bb index 7c6c9ddda3..4df47c3c5d 100644 --- a/meta-python/recipes-devtools/python/python3-scikit-build-core_0.10.7.bb +++ b/meta-python/recipes-devtools/python/python3-scikit-build-core_0.10.7.bb | |||
@@ -9,6 +9,7 @@ DEPENDS = "python3-hatch-vcs-native" | |||
9 | 9 | ||
10 | inherit pypi python_hatchling | 10 | inherit pypi python_hatchling |
11 | 11 | ||
12 | SRC_URI += "file://0001-builder.py-Check-PYTHON_INCLUDE_DIR.patch" | ||
12 | SRC_URI[sha256sum] = "04cbb59fe795202a7eeede1849112ee9dcbf3469feebd9b8b36aa541336ac4f8" | 13 | SRC_URI[sha256sum] = "04cbb59fe795202a7eeede1849112ee9dcbf3469feebd9b8b36aa541336ac4f8" |
13 | 14 | ||
14 | BBCLASSEXTEND = "native nativesdk" | 15 | BBCLASSEXTEND = "native nativesdk" |