summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-astor/f820f3ff7ad8818475b6e107e63aa9a54252d2a9.patch22
1 files changed, 19 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-astor/f820f3ff7ad8818475b6e107e63aa9a54252d2a9.patch b/meta-python/recipes-devtools/python/python3-astor/f820f3ff7ad8818475b6e107e63aa9a54252d2a9.patch
index 823699339e..6d71be9927 100644
--- a/meta-python/recipes-devtools/python/python3-astor/f820f3ff7ad8818475b6e107e63aa9a54252d2a9.patch
+++ b/meta-python/recipes-devtools/python/python3-astor/f820f3ff7ad8818475b6e107e63aa9a54252d2a9.patch
@@ -3,14 +3,27 @@ From: Jonathan Ringer <jonringer117@gmail.com>
3Date: Thu, 17 Oct 2019 16:54:16 -0700 3Date: Thu, 17 Oct 2019 16:54:16 -0700
4Subject: [PATCH] Fix packaging for setuptools>=41.4 4Subject: [PATCH] Fix packaging for setuptools>=41.4
5 5
6Upstream-Status: Pending
7
8Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
6--- 9---
10 MANIFEST.in | 1 +
7 astor/VERSION | 1 + 11 astor/VERSION | 1 +
8 astor/__init__.py | 5 ++++- 12 astor/__init__.py | 5 ++++-
9 setup.cfg | 3 ++- 13 setup.cfg | 3 ++-
10 setup.py | 16 +--------------- 14 setup.py | 16 +---------------
11 4 files changed, 8 insertions(+), 17 deletions(-) 15 5 files changed, 9 insertions(+), 17 deletions(-)
12 create mode 100644 astor/VERSION 16 create mode 100644 astor/VERSION
13 17
18diff --git a/MANIFEST.in b/MANIFEST.in
19index b12a6fe..81e72d5 100644
20--- a/MANIFEST.in
21+++ b/MANIFEST.in
22@@ -1,3 +1,4 @@
23 include README.rst AUTHORS LICENSE CHANGES
24 include setuputils.py
25+include astor/VERSION
26 recursive-include tests *.py
14diff --git a/astor/VERSION b/astor/VERSION 27diff --git a/astor/VERSION b/astor/VERSION
15new file mode 100644 28new file mode 100644
16index 0000000..a3df0a6 29index 0000000..a3df0a6
@@ -22,7 +35,7 @@ diff --git a/astor/__init__.py b/astor/__init__.py
22index 3b02983..8dfcdb1 100644 35index 3b02983..8dfcdb1 100644
23--- a/astor/__init__.py 36--- a/astor/__init__.py
24+++ b/astor/__init__.py 37+++ b/astor/__init__.py
25@@ -9,6 +9,7 @@ 38@@ -9,6 +9,7 @@ Copyright 2013 (c) Berker Peksag
26 39
27 """ 40 """
28 41
@@ -30,7 +43,7 @@ index 3b02983..8dfcdb1 100644
30 import warnings 43 import warnings
31 44
32 from .code_gen import SourceGenerator, to_source # NOQA 45 from .code_gen import SourceGenerator, to_source # NOQA
33@@ -19,7 +20,9 @@ 46@@ -19,7 +20,9 @@ from .op_util import get_op_symbol, get_op_precedence # NOQA
34 from .op_util import symbol_data # NOQA 47 from .op_util import symbol_data # NOQA
35 from .tree_walk import TreeWalk # NOQA 48 from .tree_walk import TreeWalk # NOQA
36 49
@@ -85,3 +98,6 @@ index 4a111b5..6068493 100644
85 98
86-setup(**config['options']) 99-setup(**config['options'])
87+setup() 100+setup()
101--
1022.21.0
103