diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-eventlet/d19ad6cc086684ee74db250f5fd35227c98e678a.patch | 13 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-eventlet_0.39.0.bb (renamed from meta-python/recipes-devtools/python/python3-eventlet_0.37.0.bb) | 2 |
2 files changed, 10 insertions, 5 deletions
diff --git a/meta-python/recipes-devtools/python/python3-eventlet/d19ad6cc086684ee74db250f5fd35227c98e678a.patch b/meta-python/recipes-devtools/python/python3-eventlet/d19ad6cc086684ee74db250f5fd35227c98e678a.patch index f8a268309a..fd0fc91d25 100644 --- a/meta-python/recipes-devtools/python/python3-eventlet/d19ad6cc086684ee74db250f5fd35227c98e678a.patch +++ b/meta-python/recipes-devtools/python/python3-eventlet/d19ad6cc086684ee74db250f5fd35227c98e678a.patch | |||
@@ -11,17 +11,22 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
11 | 1 file changed, 7 insertions(+) | 11 | 1 file changed, 7 insertions(+) |
12 | 12 | ||
13 | diff --git a/eventlet/green/thread.py b/eventlet/green/thread.py | 13 | diff --git a/eventlet/green/thread.py b/eventlet/green/thread.py |
14 | index 053a1c3c6..384b3c290 100644 | 14 | index 224cd1c..c70c9e8 100644 |
15 | --- a/eventlet/green/thread.py | 15 | --- a/eventlet/green/thread.py |
16 | +++ b/eventlet/green/thread.py | 16 | +++ b/eventlet/green/thread.py |
17 | @@ -118,3 +118,10 @@ def stack_size(size=None): | 17 | @@ -174,5 +174,12 @@ from eventlet.corolocal import local as _local |
18 | |||
19 | if hasattr(__thread, 'daemon_threads_allowed'): | 18 | if hasattr(__thread, 'daemon_threads_allowed'): |
20 | daemon_threads_allowed = __thread.daemon_threads_allowed | 19 | daemon_threads_allowed = __thread.daemon_threads_allowed |
21 | + | 20 | |
22 | +if hasattr(__thread, 'start_joinable_thread'): | 21 | +if hasattr(__thread, 'start_joinable_thread'): |
23 | + start_joinable_thread = __thread.start_joinable_thread | 22 | + start_joinable_thread = __thread.start_joinable_thread |
24 | + _shutdown = __thread._shutdown | 23 | + _shutdown = __thread._shutdown |
25 | + _make_thread_handle = __thread._make_thread_handle | 24 | + _make_thread_handle = __thread._make_thread_handle |
26 | + _ThreadHandle = __thread._ThreadHandle | 25 | + _ThreadHandle = __thread._ThreadHandle |
27 | + _get_main_thread_ident = __thread._get_main_thread_ident | 26 | + _get_main_thread_ident = __thread._get_main_thread_ident |
27 | + | ||
28 | if hasattr(__thread, '_shutdown'): | ||
29 | _shutdown = __thread._shutdown | ||
30 | -- | ||
31 | 2.43.0 | ||
32 | |||
diff --git a/meta-python/recipes-devtools/python/python3-eventlet_0.37.0.bb b/meta-python/recipes-devtools/python/python3-eventlet_0.39.0.bb index df23162e05..99f11b104f 100644 --- a/meta-python/recipes-devtools/python/python3-eventlet_0.37.0.bb +++ b/meta-python/recipes-devtools/python/python3-eventlet_0.39.0.bb | |||
@@ -5,7 +5,7 @@ LICENSE = "MIT" | |||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=56472ad6de4caf50e05332a34b66e778" | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=56472ad6de4caf50e05332a34b66e778" |
6 | 6 | ||
7 | SRC_URI += "file://d19ad6cc086684ee74db250f5fd35227c98e678a.patch" | 7 | SRC_URI += "file://d19ad6cc086684ee74db250f5fd35227c98e678a.patch" |
8 | SRC_URI[sha256sum] = "fa49bf5a549cdbaa06919679979ea022ac8f8f3cf0499f26849a1cd8e64c30b1" | 8 | SRC_URI[sha256sum] = "01ba0aa6ee2452690fc02b274a2409598a13b997c7b5af9dc66600fa42015a79" |
9 | 9 | ||
10 | inherit pypi python_hatchling | 10 | inherit pypi python_hatchling |
11 | 11 | ||