summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-pylint.inc38
-rw-r--r--meta-python/recipes-devtools/python/python3-pylint_1.8.3.bb40
2 files changed, 38 insertions, 40 deletions
diff --git a/meta-python/recipes-devtools/python/python-pylint.inc b/meta-python/recipes-devtools/python/python-pylint.inc
deleted file mode 100644
index ba85b98878..0000000000
--- a/meta-python/recipes-devtools/python/python-pylint.inc
+++ /dev/null
@@ -1,38 +0,0 @@
1SUMMARY="Pylint is a Python source code analyzer"
2HOMEPAGE= "http://www.pylint.org/"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4"
5
6SRC_URI[md5sum] = "2eb5f3cb8fe567eaf5420dd415012202"
7SRC_URI[sha256sum] = "c77311859e0c2d7932095f30d2b1bfdc4b6fe111f534450ba727a52eae330ef2"
8
9inherit pypi
10
11DEPENDS += "${PYTHON_PN}-pytest-runner-native"
12
13do_install_append(){
14 rm ${D}${bindir}/pylint
15 cat >> ${D}${bindir}/pylint <<EOF
16#!/usr/bin/env ${PYTHON_PN}
17from pylint import run_pylint
18run_pylint()
19EOF
20 chmod 755 ${D}${bindir}/pylint
21 sed -i -e 's:^#!/usr/bin/python:#!/usr/bin/env\ ${PYTHON_PN}:g' ${D}/${PYTHON_SITEPACKAGES_DIR}/pylint/test/data/ascript
22}
23
24PACKAGES =+ "${PN}-tests"
25FILES_${PN}-tests+= " \
26 ${PYTHON_SITEPACKAGES_DIR}/pylint/test/ \
27 ${PYTHON_SITEPACKAGES_DIR}/pylint/testutils.py \
28"
29
30RDEPENDS_${PN} += "${PYTHON_PN}-astroid \
31 ${PYTHON_PN}-isort \
32 ${PYTHON_PN}-numbers \
33 ${PYTHON_PN}-shell \
34 ${PYTHON_PN}-json \
35 ${PYTHON_PN}-pkgutil \
36 ${PYTHON_PN}-difflib \
37 ${PYTHON_PN}-netserver \
38 "
diff --git a/meta-python/recipes-devtools/python/python3-pylint_1.8.3.bb b/meta-python/recipes-devtools/python/python3-pylint_1.8.3.bb
index 563e8316cf..7a873a1e12 100644
--- a/meta-python/recipes-devtools/python/python3-pylint_1.8.3.bb
+++ b/meta-python/recipes-devtools/python/python3-pylint_1.8.3.bb
@@ -1,2 +1,38 @@
1inherit setuptools3 python3-dir 1SUMMARY="Pylint is a Python source code analyzer"
2require python-pylint.inc 2HOMEPAGE= "http://www.pylint.org/"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4"
5
6SRC_URI[md5sum] = "2eb5f3cb8fe567eaf5420dd415012202"
7SRC_URI[sha256sum] = "c77311859e0c2d7932095f30d2b1bfdc4b6fe111f534450ba727a52eae330ef2"
8
9inherit pypi setuptools3 python3-dir
10
11DEPENDS += "${PYTHON_PN}-pytest-runner-native"
12
13do_install_append(){
14 rm ${D}${bindir}/pylint
15 cat >> ${D}${bindir}/pylint <<EOF
16#!/usr/bin/env ${PYTHON_PN}
17from pylint import run_pylint
18run_pylint()
19EOF
20 chmod 755 ${D}${bindir}/pylint
21 sed -i -e 's:^#!/usr/bin/python:#!/usr/bin/env\ ${PYTHON_PN}:g' ${D}/${PYTHON_SITEPACKAGES_DIR}/pylint/test/data/ascript
22}
23
24PACKAGES =+ "${PN}-tests"
25FILES_${PN}-tests+= " \
26 ${PYTHON_SITEPACKAGES_DIR}/pylint/test/ \
27 ${PYTHON_SITEPACKAGES_DIR}/pylint/testutils.py \
28"
29
30RDEPENDS_${PN} += "${PYTHON_PN}-astroid \
31 ${PYTHON_PN}-isort \
32 ${PYTHON_PN}-numbers \
33 ${PYTHON_PN}-shell \
34 ${PYTHON_PN}-json \
35 ${PYTHON_PN}-pkgutil \
36 ${PYTHON_PN}-difflib \
37 ${PYTHON_PN}-netserver \
38 "