summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/conf/include/ptest-packagelists-meta-python.inc1
-rw-r--r--meta-python/recipes-devtools/python/python3-portion/run-ptest3
-rw-r--r--meta-python/recipes-devtools/python/python3-portion_2.5.0.bb22
3 files changed, 23 insertions, 3 deletions
diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc
index 8f739f24f8..196ff6a734 100644
--- a/meta-python/conf/include/ptest-packagelists-meta-python.inc
+++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc
@@ -48,6 +48,7 @@ PTESTS_FAST_META_PYTHON = "\
48 python3-platformdirs \ 48 python3-platformdirs \
49 python3-polyline \ 49 python3-polyline \
50 python3-portalocker \ 50 python3-portalocker \
51 python3-portion \
51 python3-precise-runner \ 52 python3-precise-runner \
52 python3-prettytable \ 53 python3-prettytable \
53 python3-propcache \ 54 python3-propcache \
diff --git a/meta-python/recipes-devtools/python/python3-portion/run-ptest b/meta-python/recipes-devtools/python/python3-portion/run-ptest
new file mode 100644
index 0000000000..8d2017d39c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-portion/run-ptest
@@ -0,0 +1,3 @@
1#!/bin/sh
2
3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-portion_2.5.0.bb b/meta-python/recipes-devtools/python/python3-portion_2.5.0.bb
index f4e5d2036e..269473e933 100644
--- a/meta-python/recipes-devtools/python/python3-portion_2.5.0.bb
+++ b/meta-python/recipes-devtools/python/python3-portion_2.5.0.bb
@@ -5,12 +5,28 @@ SECTION = "devel/python"
5LICENSE = "LGPL-3.0-only" 5LICENSE = "LGPL-3.0-only"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3000208d539ec061b899bce1d9ce9404" 6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3000208d539ec061b899bce1d9ce9404"
7 7
8inherit pypi python_setuptools_build_meta 8inherit pypi python_setuptools_build_meta ptest
9 9
10SRC_URI[sha256sum] = "80ae7bab71f4844e3eb33c57954d76a3bd4cb351039b6e260e779325aeb4a487" 10SRC_URI[sha256sum] = "80ae7bab71f4844e3eb33c57954d76a3bd4cb351039b6e260e779325aeb4a487"
11 11
12RDEPENDS:${PN} = "\ 12SRC_URI += " \
13 python3-sortedcontainers \ 13 file://run-ptest \
14" 14"
15 15
16RDEPENDS:${PN} += "\
17 python3-sortedcontainers \
18"
19
20RDEPENDS:${PN}-ptest += " \
21 python3-pytest \
22 python3-unittest-automake-output \
23"
24
25do_install_ptest() {
26 install -d ${D}${PTEST_PATH}/tests
27 # This file tests README.md and deleted as redundant.
28 rm -f ${S}/tests/test_doc.py
29 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
30}
31
16BBCLASSEXTEND = "native" 32BBCLASSEXTEND = "native"