summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-dominate/fix-ptests.patch20
-rw-r--r--meta-python/recipes-devtools/python/python3-dominate_2.9.0.bb (renamed from meta-python/recipes-devtools/python/python3-dominate_2.8.0.bb)5
2 files changed, 2 insertions, 23 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dominate/fix-ptests.patch b/meta-python/recipes-devtools/python/python3-dominate/fix-ptests.patch
deleted file mode 100644
index 81211d4498..0000000000
--- a/meta-python/recipes-devtools/python/python3-dominate/fix-ptests.patch
+++ /dev/null
@@ -1,20 +0,0 @@
1Fixes test failures on musl
2
3Fixes errors
4ptestresult.python3-dominate.tests/test_dom_tag.py::test___get_thread_context
5
6Upstream-Status: Pending
7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8
9diff --git a/tests/test_dom_tag.py b/tests/test_dom_tag.py
10index 43ffecb..1126e54 100644
11--- a/tests/test_dom_tag.py
12+++ b/tests/test_dom_tag.py
13@@ -18,6 +18,7 @@ def test___get_thread_context(monkeypatch):
14 monkeypatch.setattr(sut, 'threading', threading)
15
16 assert sut._get_thread_context() in [
17+ 1692341442, # Python >= 3.9, 32-bit
18 -6805948436281256182, # Python >= 3.9
19 3713141171098444831, # Python < 3.9
20 ]
diff --git a/meta-python/recipes-devtools/python/python3-dominate_2.8.0.bb b/meta-python/recipes-devtools/python/python3-dominate_2.9.0.bb
index 6b0489e4fd..2234e541b7 100644
--- a/meta-python/recipes-devtools/python/python3-dominate_2.8.0.bb
+++ b/meta-python/recipes-devtools/python/python3-dominate_2.9.0.bb
@@ -2,13 +2,12 @@ SUMMARY = "Dominate is a Python library for creating and manipulating HTML docum
2LICENSE = "LGPL-3.0-only" 2LICENSE = "LGPL-3.0-only"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b52f2d57d10c4f7ee67a7eb9615d5d24" 3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b52f2d57d10c4f7ee67a7eb9615d5d24"
4 4
5SRC_URI[sha256sum] = "4c90c3befaf88e612b71f4b39af7bcbef8977acfa855cec957225a8fbf504007" 5SRC_URI[sha256sum] = "b15791ebea432218543a1702d76ae45d2ff95ff994e52014b8686a69dad772fd"
6 6
7inherit pypi setuptools3 ptest 7inherit pypi ptest python_setuptools_build_meta
8 8
9SRC_URI += " \ 9SRC_URI += " \
10 file://run-ptest \ 10 file://run-ptest \
11 file://fix-ptests.patch \
12" 11"
13 12
14RDEPENDS:${PN}-ptest += " \ 13RDEPENDS:${PN}-ptest += " \