diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch | 26 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-matplotlib_3.6.3.bb (renamed from meta-python/recipes-devtools/python/python3-matplotlib_3.5.3.bb) | 4 |
2 files changed, 22 insertions, 8 deletions
diff --git a/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch b/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch index 25c49afb97..899cac624a 100644 --- a/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch +++ b/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch | |||
@@ -6,18 +6,32 @@ Signed-off-by: Mark Hatle <mark.hatle@xilinx.com> | |||
6 | 6 | ||
7 | --- a/setup.py | 7 | --- a/setup.py |
8 | +++ b/setup.py | 8 | +++ b/setup.py |
9 | @@ -316,8 +316,6 @@ setup( # Finally, pass this all along t | 9 | @@ -303,7 +303,6 @@ setup( # Finally, pass this all along t |
10 | setup_requires=[ | 10 | setup_requires=[ |
11 | "certifi>=2020.06.20", | 11 | "certifi>=2020.06.20", |
12 | "numpy>=1.17", | 12 | "numpy>=1.19", |
13 | - "setuptools_scm>=4,<7", | 13 | - "setuptools_scm>=7", |
14 | - "setuptools_scm_git_archive", | ||
15 | ], | 14 | ], |
16 | install_requires=[ | 15 | install_requires=[ |
17 | "cycler>=0.10", | 16 | "contourpy>=1.0.1", |
17 | @@ -315,13 +314,7 @@ setup( # Finally, pass this all along t | ||
18 | "pillow>=6.2.0", | ||
19 | "pyparsing>=2.2.1", | ||
20 | "python-dateutil>=2.7", | ||
21 | - ] + ( | ||
22 | - # Installing from a git checkout that is not producing a wheel. | ||
23 | - ["setuptools_scm>=7"] if ( | ||
24 | - Path(__file__).with_name(".git").exists() and | ||
25 | - os.environ.get("CIBUILDWHEEL", "0") != "1" | ||
26 | - ) else [] | ||
27 | - ), | ||
28 | + ], | ||
29 | use_scm_version={ | ||
30 | "version_scheme": "release-branch-semver", | ||
31 | "local_scheme": "node-and-date", | ||
18 | --- a/setupext.py | 32 | --- a/setupext.py |
19 | +++ b/setupext.py | 33 | +++ b/setupext.py |
20 | @@ -64,40 +64,7 @@ def get_from_cache_or_download(url, sha) | 34 | @@ -65,40 +65,7 @@ def get_from_cache_or_download(url, sha) |
21 | BytesIO | 35 | BytesIO |
22 | The file loaded into memory. | 36 | The file loaded into memory. |
23 | """ | 37 | """ |
diff --git a/meta-python/recipes-devtools/python/python3-matplotlib_3.5.3.bb b/meta-python/recipes-devtools/python/python3-matplotlib_3.6.3.bb index 1a0b93b030..809f9425ba 100644 --- a/meta-python/recipes-devtools/python/python3-matplotlib_3.5.3.bb +++ b/meta-python/recipes-devtools/python/python3-matplotlib_3.6.3.bb | |||
@@ -7,7 +7,7 @@ HOMEPAGE = "https://github.com/matplotlib/matplotlib" | |||
7 | SECTION = "devel/python" | 7 | SECTION = "devel/python" |
8 | LICENSE = "PSF-2.0" | 8 | LICENSE = "PSF-2.0" |
9 | LIC_FILES_CHKSUM = "\ | 9 | LIC_FILES_CHKSUM = "\ |
10 | file://setup.py;beginline=296;endline=296;md5=20e7ab4d2b2b1395a0e4ab800181eb96 \ | 10 | file://setup.py;beginline=283;endline=283;md5=20e7ab4d2b2b1395a0e4ab800181eb96 \ |
11 | file://LICENSE/LICENSE;md5=afec61498aa5f0c45936687da9a53d74 \ | 11 | file://LICENSE/LICENSE;md5=afec61498aa5f0c45936687da9a53d74 \ |
12 | " | 12 | " |
13 | 13 | ||
@@ -21,7 +21,7 @@ DEPENDS = "\ | |||
21 | python3-certifi-native \ | 21 | python3-certifi-native \ |
22 | python3-setuptools-scm-native \ | 22 | python3-setuptools-scm-native \ |
23 | " | 23 | " |
24 | SRC_URI[sha256sum] = "339cac48b80ddbc8bfd05daae0a3a73414651a8596904c2a881cfd1edb65f26c" | 24 | SRC_URI[sha256sum] = "1f4d69707b1677560cd952544ee4962f68ff07952fb9069ff8c12b56353cb8c9" |
25 | 25 | ||
26 | inherit pypi setuptools3 pkgconfig | 26 | inherit pypi setuptools3 pkgconfig |
27 | 27 | ||