diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-pymysql.inc | 18 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pymysql_0.9.3.bb | 19 |
2 files changed, 17 insertions, 20 deletions
diff --git a/meta-python/recipes-devtools/python/python-pymysql.inc b/meta-python/recipes-devtools/python/python-pymysql.inc deleted file mode 100644 index 8c7f4556cb..0000000000 --- a/meta-python/recipes-devtools/python/python-pymysql.inc +++ /dev/null | |||
@@ -1,18 +0,0 @@ | |||
1 | SUMMARY = "A pure-Python MySQL client library" | ||
2 | DESCRIPTION = " \ | ||
3 | This package contains a pure-Python MySQL client library, based on PEP 249 \ | ||
4 | Most public APIs are compatible with mysqlclient and MySQLdb. \ | ||
5 | " | ||
6 | SECTION = "devel/python" | ||
7 | HOMEPAGE = "https://pymysql.readthedocs.io" | ||
8 | LICENSE = "MIT" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=528175c84163bb800d23ad835c7fa0fc" | ||
10 | |||
11 | SRC_URI[md5sum] = "e5d9183cc0a775ac29f9e0365cca6556" | ||
12 | SRC_URI[sha256sum] = "d8c059dcd81dedb85a9f034d5e22dcb4442c0b201908bede99e306d65ea7c8e7" | ||
13 | |||
14 | inherit pypi | ||
15 | |||
16 | PYPI_PACKAGE = "PyMySQL" | ||
17 | |||
18 | RDEPENDS_${PN} += "${PYTHON_PN}-cryptography" | ||
diff --git a/meta-python/recipes-devtools/python/python3-pymysql_0.9.3.bb b/meta-python/recipes-devtools/python/python3-pymysql_0.9.3.bb index 13774bd632..6a64ccb161 100644 --- a/meta-python/recipes-devtools/python/python3-pymysql_0.9.3.bb +++ b/meta-python/recipes-devtools/python/python3-pymysql_0.9.3.bb | |||
@@ -1,2 +1,17 @@ | |||
1 | inherit setuptools3 | 1 | SUMMARY = "A pure-Python MySQL client library" |
2 | require python-pymysql.inc | 2 | DESCRIPTION = " \ |
3 | This package contains a pure-Python MySQL client library, based on PEP 249 \ | ||
4 | Most public APIs are compatible with mysqlclient and MySQLdb. \ | ||
5 | " | ||
6 | SECTION = "devel/python" | ||
7 | HOMEPAGE = "https://pymysql.readthedocs.io" | ||
8 | LICENSE = "MIT" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=528175c84163bb800d23ad835c7fa0fc" | ||
10 | |||
11 | SRC_URI[md5sum] = "e5d9183cc0a775ac29f9e0365cca6556" | ||
12 | SRC_URI[sha256sum] = "d8c059dcd81dedb85a9f034d5e22dcb4442c0b201908bede99e306d65ea7c8e7" | ||
13 | |||
14 | PYPI_PACKAGE = "PyMySQL" | ||
15 | inherit pypi setuptools3 | ||
16 | |||
17 | RDEPENDS_${PN} += "${PYTHON_PN}-cryptography" | ||