diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-grpcio/ppc-boringssl-support.patch | 2 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-grpcio/riscv64_support.patch | 2 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-grpcio_1.36.1.bb (renamed from meta-python/recipes-devtools/python/python3-grpcio_1.35.0.bb) | 2 |
3 files changed, 3 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio/ppc-boringssl-support.patch b/meta-python/recipes-devtools/python/python3-grpcio/ppc-boringssl-support.patch index dadd3da85e..5c9be443d8 100644 --- a/meta-python/recipes-devtools/python/python3-grpcio/ppc-boringssl-support.patch +++ b/meta-python/recipes-devtools/python/python3-grpcio/ppc-boringssl-support.patch | |||
@@ -12,6 +12,6 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
12 | +#elif (defined(__PPC__) || defined(__powerpc__)) | 12 | +#elif (defined(__PPC__) || defined(__powerpc__)) |
13 | +#define OPENSSL_32_BIT | 13 | +#define OPENSSL_32_BIT |
14 | +#define OPENSSL_PPC | 14 | +#define OPENSSL_PPC |
15 | #elif defined(__mips__) && !defined(__LP64__) | 15 | #elif defined(__MIPSEL__) && !defined(__LP64__) |
16 | #define OPENSSL_32_BIT | 16 | #define OPENSSL_32_BIT |
17 | #define OPENSSL_MIPS | 17 | #define OPENSSL_MIPS |
diff --git a/meta-python/recipes-devtools/python/python3-grpcio/riscv64_support.patch b/meta-python/recipes-devtools/python/python3-grpcio/riscv64_support.patch index 7e071ae1e6..350c67deaf 100644 --- a/meta-python/recipes-devtools/python/python3-grpcio/riscv64_support.patch +++ b/meta-python/recipes-devtools/python/python3-grpcio/riscv64_support.patch | |||
@@ -5,7 +5,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
5 | --- a/third_party/boringssl-with-bazel/src/include/openssl/base.h | 5 | --- a/third_party/boringssl-with-bazel/src/include/openssl/base.h |
6 | +++ b/third_party/boringssl-with-bazel/src/include/openssl/base.h | 6 | +++ b/third_party/boringssl-with-bazel/src/include/openssl/base.h |
7 | @@ -108,6 +108,14 @@ extern "C" { | 7 | @@ -108,6 +108,14 @@ extern "C" { |
8 | #elif defined(__mips__) && defined(__LP64__) | 8 | #elif defined(__MIPSEL__) && defined(__LP64__) |
9 | #define OPENSSL_64_BIT | 9 | #define OPENSSL_64_BIT |
10 | #define OPENSSL_MIPS64 | 10 | #define OPENSSL_MIPS64 |
11 | +#elif defined(__riscv) | 11 | +#elif defined(__riscv) |
diff --git a/meta-python/recipes-devtools/python/python3-grpcio_1.35.0.bb b/meta-python/recipes-devtools/python/python3-grpcio_1.36.1.bb index 2c137f6ce7..d374b54b34 100644 --- a/meta-python/recipes-devtools/python/python3-grpcio_1.35.0.bb +++ b/meta-python/recipes-devtools/python/python3-grpcio_1.36.1.bb | |||
@@ -11,7 +11,7 @@ SRC_URI_append_class-target = " file://ppc-boringssl-support.patch \ | |||
11 | file://riscv64_support.patch \ | 11 | file://riscv64_support.patch \ |
12 | file://boring_ssl.patch \ | 12 | file://boring_ssl.patch \ |
13 | " | 13 | " |
14 | SRC_URI[sha256sum] = "7bd0ebbb14dde78bf66a1162efd29d3393e4e943952e2f339757aa48a184645c" | 14 | SRC_URI[sha256sum] = "a66ea59b20f3669df0f0c6a3bd57b985e5b2d1dcf3e4c29819bb8dc232d0fd38" |
15 | 15 | ||
16 | RDEPENDS_${PN} = "${PYTHON_PN}-protobuf \ | 16 | RDEPENDS_${PN} = "${PYTHON_PN}-protobuf \ |
17 | ${PYTHON_PN}-setuptools \ | 17 | ${PYTHON_PN}-setuptools \ |