diff options
Diffstat (limited to 'meta-python')
-rw-r--r-- | meta-python/recipes-devtools/python/python-pygpgme/run-ptest | 3 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python-pygpgme_0.3.bb | 13 |
2 files changed, 14 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python-pygpgme/run-ptest b/meta-python/recipes-devtools/python/python-pygpgme/run-ptest new file mode 100644 index 0000000000..ac867e2c0a --- /dev/null +++ b/meta-python/recipes-devtools/python/python-pygpgme/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | GPG_AGENT_INFO= python test_all.py -v | ||
diff --git a/meta-python/recipes-devtools/python/python-pygpgme_0.3.bb b/meta-python/recipes-devtools/python/python-pygpgme_0.3.bb index f06c34439a..39a7adaa9a 100644 --- a/meta-python/recipes-devtools/python/python-pygpgme_0.3.bb +++ b/meta-python/recipes-devtools/python/python-pygpgme_0.3.bb | |||
@@ -7,12 +7,21 @@ SECTION = "devel/python" | |||
7 | LICENSE = "LGPL-2.1" | 7 | LICENSE = "LGPL-2.1" |
8 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=6517bdc8f2416f27ab725d4702f7aac3" | 8 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=6517bdc8f2416f27ab725d4702f7aac3" |
9 | 9 | ||
10 | SRC_URI = "https://pypi.python.org/packages/source/p/pygpgme/pygpgme-${PV}.tar.gz" | 10 | SRC_URI = "https://pypi.python.org/packages/source/p/pygpgme/pygpgme-${PV}.tar.gz \ |
11 | file://run-ptest \ | ||
12 | " | ||
13 | |||
11 | SRC_URI[md5sum] = "d38355af73f0352cde3d410b25f34fd0" | 14 | SRC_URI[md5sum] = "d38355af73f0352cde3d410b25f34fd0" |
12 | SRC_URI[sha256sum] = "5fd887c407015296a8fd3f4b867fe0fcca3179de97ccde90449853a3dfb802e1" | 15 | SRC_URI[sha256sum] = "5fd887c407015296a8fd3f4b867fe0fcca3179de97ccde90449853a3dfb802e1" |
13 | 16 | ||
14 | S = "${WORKDIR}/pygpgme-${PV}" | 17 | S = "${WORKDIR}/pygpgme-${PV}" |
15 | 18 | ||
16 | DEPENDS += "gpgme" | 19 | DEPENDS += "gpgme" |
20 | RDEPENDS_${PN} += "gnupg" | ||
21 | |||
22 | inherit setuptools ptest | ||
17 | 23 | ||
18 | inherit setuptools | 24 | do_install_ptest(){ |
25 | install ${S}/test_all.py ${D}${PTEST_PATH} | ||
26 | cp -r ${S}/tests ${D}${PTEST_PATH} | ||
27 | } | ||