summaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python-dbus_1.2.0.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-dbus_1.2.0.bb b/meta-python/recipes-devtools/python/python-dbus_1.2.0.bb
new file mode 100644
index 0000000000..95ba920d04
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-dbus_1.2.0.bb
@@ -0,0 +1,31 @@
1SUMMARY = "Python bindings for the DBus inter-process communication system"
2SECTION = "devel/python"
3HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=0b83047ce9e948b67c0facc5f233476a"
6DEPENDS = "expat dbus dbus-glib virtual/libintl python-pyrex-native"
7
8SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \
9"
10
11SRC_URI[md5sum] = "b09cd2d1a057cc432ce944de3fc06bf7"
12SRC_URI[sha256sum] = "e12c6c8b2bf3a9302f75166952cbe41d6b38c3441bbc6767dbd498942316c6df"
13S = "${WORKDIR}/dbus-python-${PV}"
14
15inherit distutils-base autotools pkgconfig
16
17PACKAGECONFIG ?= ""
18PACKAGECONFIG[docs] = "--enable-html-docs,--disable-html-docs,python3-docutils-native"
19PACKAGECONFIG[api-docs] = "--enable-api-docs,--disable-api-docs,python3-docutils-native python3-epydoc-native"
20
21export STAGING_LIBDIR
22export STAGING_INCDIR
23
24RDEPENDS_${PN} = "python-io python-logging python-stringold python-threading python-xml"
25
26FILES_${PN}-dev += "${libdir}/pkgconfig"
27
28do_install_append() {
29 # Remove files that clash with python3-dbus; their content is same
30 rm ${D}${includedir}/dbus-1.0/dbus/dbus-python.h ${D}${libdir}/pkgconfig/dbus-python.pc
31}